Rebuilding 2T WD My Cloud

My WD Cloud stopped working clueless, I searched the forum and other sites to get a complete rebuilding, but got bits and pieces hence thought of putting the entire steps if it helps as it took me almost a week to figure out the correct steps and make the mycloud back in a working condition.

MOST IMPORTANT Use Linux_Reader to backup the data from the WD hard disk before continuing with the below steps. You will have to unbox the device use a SATA adapter to connect the WD hard disk to the USB of your PC

  1. Download SystemRescueCd from

  2. Write the image in to a file using CD burn software I used imageburn

  3. Download vergin image from

  4. Download 7z to unzip the file to get rootfs.img, folder structure where the file can be found sq-040401-112-20151013.deb\sq-040401-112-20151013\data\CacheVolume\upgrade

  5. Unzip the Virgin Image, and copy the rootfs.img file to a USB Drive.

  6. Change the boot sequence of the PC to boot SystemRescueCd from CD

  7. After booting when prompted directly start the graphical environment (follow the instruction displayed in the screen , it is pretty intuitive)

  8. Attach WD hard disk using SATA adapter to one of the USB drives

  9. Connect the USB drive with the virgin image

  10. In the terminal window Use parted to see what name you have for your WD’s HDD. Run parted utility: follow below steps

  11. parted
    1.1 Print all – this will display all the storage devices

  12. select /dev/sdb (assuming this the WD hard disk else use respective name)

  13. Type “print” for see what partitions exist on disk

  14. Remove all: Type “rm 1” (where 1 - number of partition, continue this for all partitions)

  15. Crete new table:
    mklabel gpt
    mkpart primary 528M 2576M
    mkpart primary 2576M 4624M
    mkpart primary 16M 528M
    mkpart primary 4828M -1M
    mkpart primary 4624M 4724M
    mkpart primary 4724M 4824M
    mkpart primary 4824M 4826M
    mkpart primary 4826M 4828M
    set 1 raid on
    set 2 raid on

  16. Ok, type “quit”

  17. Format data partition:
    7.1 mkfs -t ext4 /dev/sdb4
    7.2 Use Gparted graphics window to format dev/sdb3 to linux-swap file system (right click on the partition you will get the option to format and the list of file system to use)
    7.3 go to parted utility again,
    select /dev/sdb (assuming this the WD hard disk else use respective name)
    set 3 msftdata on
    set 4 msftdata on
    set 5 msftdata on
    set 6 msftdata on
    set 7 msftdata on
    set 8 msftdata on
    8-1. Prepare main RAID partition (For rootfs): mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2
    The above step may error in that case run mdadm --stop /dev/md127 (Sometimes you can see another numbers - see in: ls /dev | grep md)
    Type “watch cat /proc/mdstat” and wait 100%. Then - [ctrl] + [c] for close. (Must complete this step)
    8-2. Stop auto-loaded raid: mdadm --stop /dev/md127 (Sometimes you can see another numbers - see in: ls /dev | grep md)
    8-3. Start normal raid (/dev/md0 is important!): mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2

  18. Mount USB drive
    mkdir /mnt/usb
    mount -t ntfs /dev/sdb1 /mnt/usb
    ls /mnt/usb --should show rootfs.img

  19. dd if=rootfs.img of=/dev/sdb1

  20. dd if=rootfs.img of=/dev/sdb2

  21. Shutdown PC.
    shutdown -p -H 0

  22. Connect HDD to WD’s plate and turn on WDMyCloud. Wait ~5-10 min.

  23. Once the blue light comes, got to http:\mywdcloud.local\UI\ click cancel if it asks to create username

  24. Upgrade the firmaware from the UI console, after the WD MYcloud will boot automatically but http:\mywdcloud.local\UI\ may not come up

  25. Do a system reset by, remove the power code, press the reset button, plug the power code back while the reset button is pressed, release the button after the LED blinks indicating restart (~40sec)

  26. Once the WD MYcloud reboots you have a fresh WDMyCloud

1 Like

For USB:

1)Download GParted Downloads or SystemRescueCD as in OP.
2)Use win32DiskImager to write above image on USB. If used binary zip, no need to install on system. The program is easy to use with just browse & select image file to write, USB drive to write and pressing of write button.

You’ve new steps 17(7.2-8) which I’ve not seen on other guides. I used the guide & 2TB image by Djh816. Worked perfectly even when I deleted my HD on OMV :cry:. I think the 2TB virgin image does format HD and create partition table itself. I’ll try next time if again manage to fugde the thing :grin: as not too keen to do it after 7/8 attempts in last 3 days :relieved:

Other guides:

How to Unbrick 2TB/3TB/4TB by Ouglee
Debrick guide by Djh816
How to replace or restore by Fox_exe

Note: I’d the same problem as below using 04.01.02-417 image.

This thread will be easier to look up next time for myself. Anyway thanks for posting another guide.

First I tried without steps 7.2 - 8, it didn’t work for me so I did the whole steps again this time included 7.2 to 8 and it worked fine.
Also I noticed with out writing kernel img and config img the wdcloud will come up fine. I also tried writing the image in single partition, it didn’t create partition table and WDMYCloud boot failed with solid white LED.

May be all additional steps I had to take because I formatted the whole disk and stared as if it is a fresh disk.

Messed up again trying to install DSM. Deleted all partitions and tried your method. Didn’t worked as was not getting any IP for my cloud. You’re right though as WD virgin image doesn’t make partition table. Once manually made partition table, I installed using old 3.0 virgin image. Updating FW now.

Where you able to bring it up?