Rebuild your My Cloud or upgrade the HDD on it

Raphael

Look here.

http://www.bestbuy.com/site/hard-drives/network-tablet-hard-drives/abcat0504004.c?id=abcat0504004

Shows a 6th for 296.99.

RAC

rac8006 wrote:

Raphael

 

Look here.

 

http://www.bestbuy.com/site/hard-drives/network-tablet-hard-drives/abcat0504004.c?id=abcat0504004

 

Shows a 6th for 296.99.

 

 

RAC

nice… except I live up here in Vancouver, BC, Canada :slight_smile:

Thanks for trying…

Hi and thanks to all of you for the support and share your Knowledge.

I sido install a 1tb hdd on my wd my cloud using the fox_exe method, everithing is ok, but when i upgrade to firmware 4.*** the main web Page (localhost/gui) doesnt work, I can see the shares on my Windows pc and reach the twonky web acces(localhost:9000). Thats a little bit weird. Any help or idea?

I can connect the drive to my mac simply by plugging it in via ethernet. Not sure if it’ll work with windows though.

Was anyone successful replacing the HDD with 6TB already?

Hey guys,

I tried to follow this instruction with the 2TB Image and a 4TB HDD, but unfortunately I had to skip #14 and 15 because I didn’t received an error. After typing in unit s + p, I only got an overview about 2 existing sectors (not 4 as it’s written here). Furthermore, the start sector of the last partition (which was 2 in my case) was 77056s.

I continued with step 16 (but didn’t got a warning again) and finished the instruction, but currently I only get a permanent white LED and can’t connect with the software.
Do you have an idea what I’m doing wrong or another solution?

Thanks and best regards!

Hi I’m hoping some clever person could help me… I’ve tried several times to get the mycloud up and running with a WD Red 3TB drive (and the drive proves to be fine). I get all the said partitions and everything looks correct to my untrained eye, but when I reassemble the Mycloud and plug it back in, I get a flashing blue light for about 5 seconds which then changes to a red flashing light. Any ideas what I might be doing wrong?
I’ve tried several virgin images all with the same result.
Please help me before I take a bat to it :cricket_bat_and_ball:

Did you do a 40 second reset after reassembling the My Cloud?

A user here has put together a variety of directions for replacing the My Cloud hard drive.
Gen 1 (v3.x/v4.x): https://drive.google.com/drive/folders/0B_6OlQ_H0PxVZTBtM3EyRVhDVms
Gen 2 (v2.x): https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU

Hi. Could someone upload a 3tb virgin image of disk, pls? Need it :frowning:

Thank you…

Hello everyone. I read a lot of guides like this now, finally I don’t have any idears left to get my WD My Cloud working…

Since the My Cloud has only one drive, I recently bought a My Cloud EX2 Ultra to replace it. So I put the WD Red 3 TB from the My Cloud to the EX2 Ultra and bought an additional 3 TB WD Red to configure it as a mirror for the first one for more data security. The EX2 Ultra works flawlessly so far - so far, so good.

Unfortunately, I did not take an image of the HDD before formatting it in the EX2 Ultra since I already found many images to do that using Linux afterwards. So I trusted in being able to get it back alive later (I already read that the My Cloud has the OS on the drive)… big mistake.

I have a 2 GB WD Green drive that I’m planning to use for the “old” My Cloud. So I set up a virtual machine with Lubuntu and tried everything I read here and in other forums or blogs.

This one here was the most technical advanced i’ve read: https://eriffoorp.wordpress.com/2015/05/28/replace-a-hard-drive-on-wd-my-cloud-3/ - So I even tried to rebuild the virtual RAID 1 on the drive and so on.

The images of the Gen. 1 WD My Cloud do not work on Gen. 2, so the only things left where the guide mentioned above with the Google Drive Mirror of it: https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXF4aFpYS2dzMEE

But that recovery kernel I loaded there did not accept the Firmware. The My Cloud booted to the recovery mode as expected and asked for a firmware image, but the progress counter always stayed at 0% - even with fully formated partitions and even created and ext4 formatted RAID 1 partitions on it for the Firmware.

I even tried to get Ubuntu running on it (you get the files from the Google Drive mentioned above), but Ubuntu did not start any server - neither the web interface, nor SSH was reachable afterwards.

I contacted the WD support, but - surprise, surprise - no response yet.

The only way to get the bricked thing back running would be a working image of a gen 2 WD My Cloud I guess…

Just found an Gen. 2 Image in an russian forum: http://wdnas.ml/wd/Cloud_gen2/restore/

I try it…

UPDATE: That worked perfectly - case closed for me :slight_smile:

Note: For my method (Google.drive links / Boot from USB) - try to upload old firmware (v2.0.112)

1 Like

Thanks, that explains a lot :slight_smile: I tried the latest version of course.

Can anyone please share a 2TB virgin disk image for Ex2 Ultra.

I have an EX2 Ultra with 2x2TB disks with raid 1 and I have completely messed up my disks.I do not need the data from the disk but I just want to get my EX2 Ultra working.

If I get a 2TB virgin disk image for EX2 Ultra I think I will be back in business.

The EX2 Ultra does not need disk images, it does not store the whole OS on the harddisk like the simple MyCloud does.

Connect the disks to a PC and remove the partition table with diskpart and it’s clean command, the EX2 should be able to reformat it. I bought my EX2 Ultra without harddisks and it had no problems using my harddisks (used the WD Red 3 TB from the simple MyCloud and another WD Red 3 TB I bought parallel to the EX2).

Or did you messed up the internal memory with the firmware? In that case, recovery would be much harder as on the simple MyCloud ist guess.

For Ex2/ultra/mirror - need access to internal flash. Its possible only from running OS (Possible to use my mini-image / recovery).
Then - reupload data to /dev/mtdblock{1,2,3,5} (Kernel, ramdisk, rootfs, configs).
Original files can be found in “GPL Source code” archive on WD website.

Dear @Fox_exe,

Could you re-share these link with me to repair MyCloud?

Thank you so much,
Philip.

I documented my restore process at https://github.com/alberttwong/wdmycloud/

Does anyone have an image suitable for the 4TB “My Cloud” please? Or will the 250GB image work if I resize the last partition afterwards? I’m sure what generation device, but it was running Debian Linux before I munted the HDD.

One can unbrick their single bay My Cloud unit using the methods posted by user Fox_exe. Note you will need to know which single bay My Cloud version you have (first gen v4.x firmware or second gen v2.x firmware) as the unbrick directions are different for each version.

The main Fox_exe repositories for multiple My Cloud models can be found here:
https://fox-exe.ru/WDMyCloud/

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
The img files needed for the first gen Fox directions can be found in the WDMyCloud-Gen1/Backups folder in the main Fox_exe respoitory link above.

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
Various files used in the second gen Fox_exe unbrick directions can be found in the WDMyCloud/WDMyCloud-Gen2 repository.

1 Like