Rebuild of RAID1 (mirror) taking a long time


#1

How long should a Raid 1 rebuild take? I’ve got a MyBook World Editon on my desk right now that had a failed drive A. Got a replacement drive from WD and installed it according to the article 1464 and followed 1496 to get the array rebuilt.

This started at 6:30pm on Saturday, Feb 6th t’s curently 10:30am  Tuesday Feb 9th and the blue rings are still spinning clockwise and the drive status still shows “synchronizing”.  I know the article said “5 hours no matter how much was on the drive” but we’re over 48 hours at this point.

Last night at 8pm I did power the device off by pressing and holding the button in the middle of the blue rings. I did not unplug the device. Both rings were off and I noticed that the drives spun down as well as the fan. I waited a few seconds and powered it back on with the same button. Almost immediately, the blue rings started their clockwise motion indicating the rebuild was in process.

Noticed that after a while the blue rings started rotating much more slowly than they were as well as fading in and out (sleep mode). It did this for a while then went back to the faster clockwise rotation.

This morning (approx 10 hours after power down/up from last night), I noticed that the rings were still rotating clockwise.

Will this rebuild ever finish? Called Tech support after 16 hours of the rebuild on Sunday, was told to wait it out.

Does anyone have an answer as to why this rebuild won’t finish.

NOTE: I can still access the files on all the shares so I know the data is good. The one otherthing I did notice is that if the rings do their “slow fade in and out rotation”, access to the shares is disabled until the rings speed up again.

Thanks for any and all help.

Tony


#2

Unfortunately there is nothing that you can do to force a rebuild. You just have to let the drive work on its own until it is completed and sometimes the rebuild can take 24-48hrs. If the drive is powered off or restarted, the rebuild will start all over again.

What I would do is unplug the power from the drive and disconnect the Ethernet cable. Let the drive sit for a few seconds. Then connect just the power and power up the drive if it doesn’t start on its own. This should trigger the RAID rebuild again if it didn’t finish the first time. When the lights on the front stop circling, attach the Ethernet cable to it and see if the rebuild is complete. Sometimes a device on the network may ping the drive and interrupt the rebuild process, by disconnecting the Ethernet, this will prevent it from happening if it is the cause. On this device the outer ring is the activity light and the inner ring will slow fill as the rebuild is completing. When the center ring is half lit, it should be at about 50% rebuild.


#3

Thanks for the fast reply! I will try everything you suggested  and report back if it worked or not.

Much appreciated!

Tony


#4

I did what you suggested above (Powered the device off, removed the ethernet cable and the power cable. Let it sit for a few minutes then plugged it back in without the ethernet cable and powered it on.

AS you said the rebuild restarted but I noticed that after just a few minutes, the blue rings started to fade ina nd out very slowly, rotating a little then after a few minutes of that, they started to rotate clockwise faster. The alternating between slow and fast continues.

This started at 6:30 last night. At 7:00am this morning, rings were still rotating and the center ring wasn’t lit but just a tiny bit.

I’ll let it sit a little while longer but there has to be a reason why the raid won’t rebuild in a timely fashion. Is there any way to see it’s progress? A log file perhaps to see if anything is wrong in teh background?

Thanks!

Tony


#5

Here we are 24 hours after  powerd the device off then back on again. Outer ring still rotating clockwise. Sometimes fast, sometimes slow while fading in and out. Inner ring isn’t glowing at all…

Hooked the ethernet back up and logged into the shared storage manager, drive status is still “Synchronizing”

I need some help here. THis drive isn’t mine, it belongs to a client and I need to get this thing back to working order. Does anyone have any other suggestions on how t get the raid1 rebuilt properly and working again.

Note: I can still access the files on the drive, luckily. I think I’m going to try and find anohter storage device I can back the data up to.

Tony


#6

Since you can access the data, I would highly recommend a backup like you mentioned. Unfortunately, this unit doesn’t have a way to see the rebuild progress. After your data is backed up to another drive turn off the unit and remove the drive that you replaced. Then do a write a zeros (using our Data Lifeguard Diagnostics http://support.wdc.com/product/download.asp?groupid=606&sid=3&lang=en) to it or delete the partition if you can so that the drive is blank. Put it back in the enclosure turn it on and go to the Shared Storage Manager > Drive Management. Click on “Format New Internal Drive”. Then it should start the RAID rebuild again. This way we will start with a clean drive and see if it helps.


#7

I will give that a shot. Thank you for getting back to me!

Tony


#8

I am unable to back up the data. For some reason the World Book goes into some sort of standby mode every 3-5 minutes even while I’m activly copying files from it to another drive. Copy operation fails and all access to the drive is suspended until it fels like waking up again.

I am guessing this is why it hasn’t rebuilt the RAID1 yet, it can’t stay “awake” long enough to complete.

The only thing I can think of is to remove the drive I just replaced (drive A) and see if it will work with just drive B in there. Hoping I can get the data off before this think dies all together.

If anyone has any suggestions, I’m open to hear them.

Thanks!

Tony


#9

Finally got the data backed up and tried the “write zero’s” suggestion above.  It’s been over 24 hours and the RAID1 is still in the process of rebuilding. I am beginning to think that htis RAID will never rebuild.

If anyone has any suggestions or is having the same issue, I’l love to hear from you.

Thanks!

Tony


#10

My mybookworld blue rings seems to have a similar problem. At first I could only see files in the public folder for the first few minutes. Now if I power up the drive I can hear the disk spinning but the lights are not showing anything.

I am thinking of disassebling the drive to see whether I can get access with an usb to sata interface. At the moment I am stil waiting for the interface to be delivered.


#11

I have a simular problem. The “A” drive failed, I then replaced it with the exact same type of drive. Went to the web based menu, formatted the drive and started the rebuild, now three days later it still has not finished. How long should a rebuild take? Should I start it over again by powering it off and then on?

I also noticed that during the rebuild, the web menu was incredibly slow.


#12

here we are 4 days later and the rebuild is still not completed. there was only about 100GB of data (25% of the drive) that was stored. is this normal? With the experience i have had with the mybook world edition, i do not feel confident in any other western digital product. After reading other posts, I am not the only one with this problem. It seems Western Digital should have a recall on all these units.