Rear USB Port 1/8 inch gap and not working with USB 3.0

The Rear USB port does not allow USB cables to seat completely.  There’s about an 1/8 gap.  With USB 2.0 devices this does not seem to cause any problems.  However, I can’t get my Hard Drive (Seagate FreeAgent GoFlex Desk 3TB) to work with a USB 3.0 cable plugged into the rear.  It works just fine when plugged into the front, and the USB Cables plugs completely into the front USB port.

This is the 3rd “WD TV Live Streaming” that I’ve gotten and they all have this flaw.  I called WD Tech Support and they claim that the USB cable plugs completely into the back of the one they have in their test area.  So it’s possible this is a manufacturing flaw.  On the 3 WDTV LS I’ve had there’s about an 1/8 inch gap from the USB cable not seating completely.  The same cables seat completely into the front port.  I also tried several cables and USB devices.  None of them seat completely into the rear of the WD TV LS, but they seat completely in the front.

I could just use a USB 2.0 cable or plug the cable into the front, but this is an issue for WD because people (like myself) will just assume that the rear port doesn’t work correctly and return the device.   If I plug something into the front port and it works fine, and it doesn’t work when plugged into the rear port my automatic assumption is that the port is defective.  I returned two of these before I finally realized it was due to the port not working with USB 3.0 cables.

I did look in the manual to see if it said the two ports were different in some way, but on page 8 it says that USB Port 2 has “The same function as USB port 1.”  Which isn’t the case.

Also, I know that the WDTV LS is technically only USB 2.0 compatible, so you could argue that it’s not guaranteed to work with a USB 3.0 cable, but there’s no reason it shouldn’t work if the ports are properly designed.

4 Likes

Dude, I think you’re the only one with that problem since it’s been a week already and no one else says so… Either your Seagate drives have different cables, or this is the intended design by WD.

I’d call them again and request a senior tech for a confirmation.

Did you got any response for this? I just try a USB 3.0 drive in the USB port 2 and the drive was recognized and it was working. Granted, the drive was a Passport USB 3.0.

This is embarassing, I can’t beleive no one had this issue before and WD didn’t respond to it. 

I am the owner of the WD TV Live Hub and yesterday I went and purchased a new WD TV Live Streaming device for my bedroom upstairs.

I have a backup 3 TB GoFlex USB 2.0/3.0 drive for my movies that I play in my WD TV Live Hub in my living room, so I decided not to waste the backup drive and have it used as well by connecting to my new WDTV Live Streaming device.

I experienced the exact same issues, when connecting the drive to the USB on the back of the device, it was not recognized and the gentleman is correct, there was about 1/8 inch of the adapter outside. Didn’t think much of it and immediately thought  the drive had some problems.

I almost gave up on it, until I read this post and connected the drive to the front  USB port, then it was recognized without any issues and all the movies were there.

This forum is a valuable source of information for anyone who has these devices.

For WD support, I was very happy when you fixed my audio issues with the Hub but this issue here in this thread shouldn’t have escaped you ! 

This is clearly a quality assurance weakness that should have been tested immediately when the USB 3.0 drives were out there.

Thank you for the person who posted this issue for everyone to see.

@Zman789 - Thanks for posting that you had the same problem.  It’s nice to know it’s not just me.

While I have no issues connecting my USB 2.0 3tb drive or my USB 3.0 1tb passport both WD.

I do notice that both my SMP’s have have a 1/8th inch gap in the front & back USB ports.

IMG_14301.jpg

All 3 of mine were from the same best buy within a week of each other, so it is possible it was just a manufacturing issue at that time. With the same hard drive, USB 2.0 would work in both ports, but 3.0 would only work in the front port.

I bought mine back when it first came out so there’s not much I can do about it now.

I have the same exact problem - see my post referenced below.

http://community.wdc.com/t5/WD-TV-Live-Streaming-Discussions/are-the-usb-ports-different/m-p/319701#M3012

Should I contact someone or leave some official feedback to WD so that they know it is a problem they need to fix?

You could try calling WD. The issue thread I had created in the issue forum was moved because that forum is only for software/firmware issues.

I’ve got the same problem with two of my USB3.0 external harddisks.

Tested the rear port with a Verbatim USB 3.0 Desktop Hard Drive and a  2TB and a Samsung S2 Portable USB 3.0 1TB .

Both hdd’s work fine on the front port, but on the port at the back of the SMP crashes after 15 to 20 minutes. The only solutions is cutting the power and reboot.

I’ve tried different firmware version, but the problem still remains. Even with the new 1.06 version.

I own this smp for over a month and read this article two weeks ago. After that I connect the drives to the front port and everything works fine.:angry:

Same problem using two SMP’s bought/exchanged from Best Buy (2012) using two different WD 1TB USB 3.0 hard drives. Crashes mid video (as quick as 7 minutes or long as 20 minutes after playing). Problem is independent of firmware or library status. The gap may be a red herring. There is a shelf of plastic over the front USB (the rear USB is flush), but this does not exclude a defect of some sort on the rear port (recall the WD TV Live Hub Power switch problem).

I have no solution as of yet. Plan on calling WD tech support.  Will try a short USB 2.0 extension cable. Problem may also be video dependent. Crashes seemed to occur more frequently with 1080p video (just a speculation at this point).

Good luck

There does seem to be issues with the rear USB port on the SMP.
I have the same issue as well. Oddly enough my Seagate 3TB USB 2.0/3.0 drive worked on the rear USB port on an earlier firmware. However my 3TB 2/3.0 WD HD does not work on the rear USB port. WD tech support via phone ALSO told me that the USB cable should connect all the way at the back which it does not… It does at the front, but not at the back. So I’m going to assume that this is a hardware defect of some kind. It still does not explain why myself and others had a 3TB drive working at the rear even with this defect?

I put in an RMA - WD told me that the RMA SMP devices have been fully tested and that the rear port will work. I’d bet money that the USB cable won’t plug in fully at the back though. I will update my findings in this thread when I get my SMP from WD. Also for anyone else possibly considering an RMA - you do not get a new SMP. It will be a used device roughly 3 months old. The tech rep said he had never heard about this issue before *rolls eyes* if you do phone tech support about this I suggest talking with the most senior tech agent.

As mentioned earlier, the gap is probably a non issue. The front port has the plastic housing which overhangs the port, this makes it look like there is no gap.

With additional testing it seems the USB 3.0 drives (WD 1TB) will consistently crash / disconnect while playing 1080p video, when connected to the rear port. A Generic USB 2.0 drive did not crash / disconnect when playing the same 1080p video file. Both drives were bus powered drives. 720p videos were problem free. This is certainly a weird glitch. May not be a hardware problem, but something which could be fixed with a firmware patch. Wondering if others with the same disconnect problem of their USB hard drives can narrow it down to 1080p files and USB 3.0 drives?

Please note that I’ve reproduced the problem on 3 different brand new WD 3rd gen SMPs.

Please post your thoughts.

Can’t believe I ran into this…just wanted to chime in that I have the same prb on my WDTV -well I think…all I know is that I cannot have my Seagate 2TB plugged all the way in, it has to stay just  a hair out and it works fine. Front port fine. As long as it is not bumped or anything it runs fine but kinda bugs me…order from Amazon and did not feel like trying to return

Scott

Is the USB 3.0 problem hardware related or could it be fixed with a future firmware update?  What is WD’s official response? 

This topic is kinda done to death at this point. I think there’s 3 threads on it now.

I’ve opted for the RMA process because I have 2 3.0 3TB drives and only the front USB port works. I’m not going to buy a USB HUB for the front when the back port should function. I was going to wait 'till I got my RMA SMP before I made a post.

Basically, Western Digital tech support is a joke. I’ve spoken with them over the phone and I’ve sent multiple e-mails regarding this issue.

Via phone and e-mail they told me I was the first person to report this issue.

I sent them the forum links to threads like this to try and draw awareness to this issue, but they just blew me off - didn’t seem to care.

So if this happens to be a firmware issue then It’s paramount for people to phone in and complain otherwise nothing will get done and you’ll forever be using the front USB port if you have this issue. 

Again - when I get my RMA device I’ll post an update and maybe even include the e-mail conversations I’ve had with WD if anyone cares. I think at this point I’ve probably spent more time trying to trouble-shoot this issue than anyone else on this forum.

I too have the USB 3.0 rear port problem and while I would love to see it be fixed with firmware, I find it hard to believe that a physical connection could be fixed with a few “ones and zeros”.

What is sad is I built a wooden bracket to house my SMP to match my entertainment center (that I also made) so that the rear port could be utilized by my Western Digital USB 3.0 hard drive and leave the front port free for the times I wanted to use a flash drive.  I now have the cord from my hard drive coming out of the front of the player and it looks like stomped _h_t that is constant reminder that Western Digital released a product without fully testing it.

Like I mentioned in a different thread, it would be to WD’s benefit to acknowledge the problem now before it manifests into something they wished they would have addressed once more folks transistion to the newer 3.0 hard drives.

Other than this issue, the player does all I want it to and does it well, but until this issue is addressed, I will not recommend one to any of my friends or family.

Have a good weekend,

DufferDan

I also have this problem with both my USB 3.0  2.5" hard disks - Transcend 640gb and HP 1Tb, I’ve only just gotten my WTDV a few days so I’m returning it and looking at alternative manufacturers.  This issue is unacceptable and Western Digital do not deserve my custom:angry:

I just received my WD TV Live today, from Amazon.  Upon testing, I also have problems connecting my 4TB Seagate HDD to the rear USB port.  I tried to unplug/replug and reboot a few time, but didn’t work.  Then I plug it into the front USB port and it worked just fine.

Next, I tested with my WB Passport 1TB HDD and plugged into the rear USB port; it worked every time.  The WD Passport also worked in the front USB port.  I think it is not related to USB 3.0 cable or plug, since both my Seagate and WD Passport drives are USB 3.0.  My feeling is that WD TV Live has some compatibility issue with other hard drive brand (ie. Seagate).  

To confirm this, does anyone have this problem when using a WD HDD plugged into the rear USB port.  My guess is that all WD drives will work on both front and rear ports.  This may be something WD did on purposed in their design or not (who knows).

AerotusX wrote:
This may be something WD did on purposed in their design or not (who knows).

Doubtful. Also, as mentioned in the other thread about this, a CnMemory USB 3 drive worked just fine attached to the back port of the SMP.