Reading from My Cloud EX2 Ultra very unstable and slow

Hi, I installed the EX2 Ultra and copied about 200GB of data on it. That worked without any problems, in case of large files with between 60 and 100 MB/s. Great!
But now I tried to read some data with no luck. When copy process starts, I get a goot speed for about 1 second. After that the speed slows down to about 300 kb/s. or 0. A 2 GB file I tried to read for about 30 minutes and got about 500 MB of it.

At the same moment writing to the EX2 workes fine.

I use Windows Explorer on fresh installed Windows 10 clients with Windows Defender.

I played around with some network settings (jumbo frame with different vaues and off, all SMB versions…) but with no luck. After most changes a reboot.

Downloading with web filemanager works with full speed.

The clients shouldn’t be the problem. Reading and writing between them is working with full speed.

I changed cables and tested from different computers.

Does anyone know this problem and has a solution?

Hello aliosha,

I would suggest you to contact WD support for assistance.

Refer the link provided below for contact information.