Reading and Writing Problems with My Book 1.5 T

I own a My Book 1.5 T Home Edition.  It is recognized by the system and seems to be hooked up correctly.

But whenever I try to move large folders to and from it, it will begin moving them at a decent speed, then suddenly freeze up, and the Estimated time to completion shoots up ridiculously.   After about 3 or 4 minutes, the speed recovers again and it works right. But without fail it freezes up again about every 5 minutes.

It does the same thing when playing video files off of it.  It will play the first 7 or 8 minutes, then will just freeze the video, and progress at about a frame per 5 seconds.  I have to exit out of the player and wait a few minutes, then the file will load again and play fine just to fail 7 minutes later.

It seems that this happens more often when reading from the drive, because I can download large files (over 2 Gigs) to the drive straight from the internet and it won’t freeze up.

I downloaded and ran the drive utility from WD, but it just says its fine, and if I run it during one of those freezes, it just freezes too, until it can finish its scan.

I am running a windows 7 64 bit operating system.  I have also tried both the Firewire and USB hookups, they both freeze in the same manner.

Any help would be appreciated.


Since there’s been no replies, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

I have the same problem with my 1.5T my book. It does not play any video. I have to reset my media player, then it play only one video.

Hi qontrol,

do you know the model number of your drive?

what format is the drive in?

how full is the drive?

what device are you trying to play videos to?

does this happen every single time you use it or does this only happen on specific video file types?