Read WD Mycloud with USB caddy

My WD Mycloud died. Is it possible to plug it into a caddy and copy off the data from the HDD?

Yes. If one uses the forum search feature, magnifying glass icon upper right, they will find numerous past discussion about removing the single bay My Cloud hard drive from it’s enclosure and reading its contents using Linux, or a Linux driver in Windows. From there one can attempt one of the various unbrick methods to either fix a corrupted firmware update on a single bay My Cloud drive or to use a new hard drive within a single bay My Cloud enclosure.

One such past discussion:

Note: If one has a My Cloud Home or My Cloud mutli bay unit those are different devices than a single bay My Cloud unit. There are specific subforums for those devices.

Any for LINUX based computers?

Any what for Linux based computers? USB to SATA adapters? Unbricking the single bay My Cloud hard drive?

Generally most if not all USB to SATA adapters will work with Linux or will work with Windows/Mac.

Most unbrick methods detailed in this subforum for the single bay My Cloud involve the use of Linux. If one isn’t running a Linux OS or Linux in a VM one can use a Linux boot disc/boot USB flash drive to boot their computer and access a single bay My Cloud hard drive that has been extracted from a My Cloud enclosure.

No password required?

No password required for what?

When one accesses the single bay My Cloud hard drive using a USB to SATA adapter they are using the computer’s operating system (Linux or Windows or Macintosh) to access the drive not the My Cloud OS/firmware to do so. Generally one will not encounter any password restrictions when access their user data to copy it over to another location or when unbricking a My Cloud hard drive, when using a USB to SATA adapter.

I mean is the data on the HDD not encrypted behind a password? I can just read the data?

The user data partition (on the first gen its partition #4, example in Linux: /sda4) is not encrypted, and does not require a password to access when one has the hard drive connected to a computer using a USB to SATA adapter.

I tried reading it with a Caddy and it doesn’t recognize it. It wants me to format the drive. Plugging into a Linux machine doesn’t show the drive under “disks.”

Sometimes one may have to “mount” the hard drive in Linux for it to be seen and accessed by Linux.

I just tried the page you sent. The HDD doesn’t appear under lsblk. However, another Seagate Iron Wolf Pro appeared