Read MKV/AC3 video


#1

Hi,

regulary when i read vidéo encoding in MKV/AC3 codec, video reading Freeze and i must be disconnect alimentation to restart payback correctly…

Any one have a solution or a explication ???

Thx


#2

Well, MKV isn’t a codec, MKV is a container.   And AC3 is an AUDIO codec.    

Which Video Codec are you using?

I don’t have this issue with any of my MKV/h264/AC3 videos…  And I have about 400 of them…


#3

I’m having the same problem. I use makemkv to rip dvd backups and it freezes my WDHD TV live on playback fro my NAS. I then have to restart the system. I would definitely be interested in the solution as I do not get continuos playback from .vob, and I have read elsewhere that .mkv containers will solve this problem. Thanks


#4

Here’s the simple answer – use Handbrake for your rips.

Use the High Standard preset and choose mkv for the container and pass through AC3 or DTS tracks (and subs, if you want them).  They will play just fine.


#5

@mkelly, I’ve tried this, but it still does not work through my twonky media server. Does it need to play via network share?, also video codec in “High profile” is "H.246 (x264) - shold I not be selecting MPEG-4? Laslty what quality level shoul this be (currently 60.78 under H.264 and 94% under MPEG-4)? Thanks


#6

As I’ve said elsewhere (sorry if I didn’t say it here) I use the High Profile standard preset in Handbrake .094 (actually I use the latest snapshot but make sure you at least have the current version of Handbrake) and I make mkv containers (so you’ll need to change from MP4 – the reason you need to do this is that WDLive won’t sync the audio properly with the MP4 container).

Now, I only play via network shares or locally attached drives.  Quite frankly, I’ve had zero success with media servers, not only on the Live but on three other “media devices”.  I really don’t think they are ready for prime time, despite some who have limited success with them.  Why use a media server when that’s really what the Live is all about?

As for the quality – don’t get fooled by the percentage slider (it will be removed in the next version of Handbrake and is already gone from the latest snapshot).  Set the  constant quality RF number to no lower than 20 (20 is actually fine for standard DVD but 22 is really all you need to use for blu-ray).  20 is the default on the High standard and you really shouldn’t be changing ANY of those defaults unless you know what you are doing (and you don’t – no offense).


#7

@mkelly,

You’re the MAN! (person :robotvery-happy:) I got it to work. I’m amazed that the size of my normal 5GB fiole is approx 1.2GB. Is this right?.  Also, can you explain what the RF output is in simple terms so that I can understand.

Thanks again


#8

cavalier wrote:

@mkelly,

 

You’re the MAN! (person :robotvery-happy:) I got it to work. I’m amazed that the size of my normal 5GB fiole is approx 1.2GB. Is this right?.  Also, can you explain what the RF output is in simple terms so that I can understand.

 

Thanks again

 

http://trac.handbrake.fr/wiki/CRFGuide


#9

Thanks RichUK, it does sound like there is a techinically lower quality though, even though the “perceived” quality is maintained.

Is there a simple solution to get the subtitles in MKV working form a NAS? or should I be using another container?

Thanks

Sanj


#10

I have subs in all my mkv files.

If you are ripping from a DVD you can rip the subs right in Handbrake (just to go the subtitle tab and choose the track(s) you want).

If you are ripping from a blu-ray disc it’s a little more complicated (not impossible and not hard, just more complicated).  But I won’t try explaining unless you need the explanation.


#11

I’ve used handbrake and the subs do come up but they can’t be turned on/off via options. It’s like are permanently displayed as part of the movie. I assume this is what is called “burned in”. Is there a setting in handbrake where I can still the subs on an optional basis?

Thanks


#12

Handbrake cannot burn subs in – what has most likely happened is that you set the “forced on” flag, which means they will always be displayed, no matter what.

You can’t change this in the Live (that’s kind of the whole point of the “forced” flag :>) but you can alter this with mkvmerge (freeware) for example.  Just load the file back in, select the subtitle track, and under general options turn the forced flag to “off”.  Write out the file (it won’t reencode, just remux) and you will be good to go (and in the future make sure you don’t set this flag in Handbrake).


#13

Hi I’ve tried loading with MKvmerg GUI and it strangley does not show the subtitle file. It shows three files as follows:-

(1) V_MPEG4/ISO/AVC (ID 1, TYPE: VIDEO)

(2)  A_AAAC (ID 2, TYPE: AUDIO)

(3) CHAPERS (34 ENTRIES)

The subtitles are clearly their when I play. Also, isn’t the “forced” setting referring to “forced” subtitles you get on some movies with elements of a foregin language e.g Lord of the rings when the elves are talking?

Anyway, further advise always welcome?

Thanks


#14

Hmmm. HandBrake DOES do Burned In subtitles as an option; at least, certain versions do.

I’m using the Linux build of 0.9.4

At any rate, to answer you question:

Paraphrasing  the docs:

With MKVs, you can Pass-thru MULTIPLE VobSub tracks.  If you mark one as Default, and your player supports it, that track will be displayed automatically.  You can BURN IN a track into the video stream.  

So, when you rip with Subtitles enabled, make sure the BURNED IN option is NOT selected with any of your tracks.


#15

Sorry – I was thinking of SRT subtitles, which you cannot burn in in Handbrake (and, of course, you can’t do blu-ray subs in Handbrake, which are the only ones that I am concerned with nowadays since I add them after encoding).

However, forcing a subtitle track is the same whether you have “normal” subtitles or you have them as in portions of your video (like with 2012) – once the flag is set to forced then it will always display.

So if you did encode them in Handbrake (and they were NOT SRT subs) and you had the burned in option checked you did indeed burn them into the video and will need to reencode those videos to have the option to turn them off .


#16

I’ve reconverted one of the dvd’s and unchecked the subtitle from “Burned in”/“forced” and made it “default”. This works via network share and wait for it…it also works via the Twonky server :smileyvery-happy: Yipppeeee! . If I created this posting then I would mark it as solved, but its not mine, so thanks for your all your advice in solving this issue.