Re: My Passport Ultra 2TB for Mac

I have purchased 2 TB My Passport Ultra for Mac. 

It worked perfectly with my MacBook Pro for a few weeks, and all of a sudden, MacBookPro stopped recognizing it. 

I would plug the drive in, it would power up the LED, and I can hear it spinning, but it does not show up in the Finder. I have moved some critical files to it already, and formatting or swapping to a new one is not an option. 

How can I make it to show up again? 

Thank you!

I was able to see my drive in the Disk Utility, although greyed out. It said Unmounted, but when I hit Mount button, nothing happens. It says that the drive is locked, but when I run WD Security, it says Security is not enabled for this drive. 

What could be an issue? 


Hi, be sure to connect the Passport directly to the Mac, avoid using extension cables or USB hubs since these might cause power inconsistencies. 

It is connected with the cable. It seems not to be the problem, because it does see it in Disk Utility, it’s that it is just not mounting it.