Re: HOWTO: Recover files from a RAID 1 (mirrored) drive Mybook world

HI I hope someone can assist


I am trying to recover my data from a Mybookworld that has failed

2 x 2terrabyte drives in raid 1  Mirror


I found the following fantastically detailed topic in the archive by Jason in 2011 which covers my problem perfectly…  This was written by Jason


Re: HOWTO: Recover files from a RAID 1 (mirrored) drive when the ShareSpace has failed.


‎03-23-2011 12:13 PM




I get to the point  where I try to mount my drive with the command


 sudo mount -t ext3 -o ro /dev/sdc /mnt

I get the message  


sudo mount -t ext3 -o ro /dev/sdc /mnt

Wha do I do next… I need to recovr my data…


Please help


HOWTO: Recover files from a RAID 1 (mirrored) drive when the ShareSpace has failed.


‎02-18-2011 12:22 PM

Lately I’ve been hearing that some of you have read on the Internet where you can take a RAID 1 (mirrored) drive out of a ShareSpace, put it in a computer, and use an Ubuntu Desktop CD to recover your data, but no tutorials exist.  Since you read it on the Internet it must be true, so I decided to write an illustrated tutorial to help out.  Big, huge thanks to WDJeremy for preparing a ShareSpace drive for me to work on.

First things first - RAID gives you redundancy, and is not a backup.  It is okay to use a RAID array as your backup location.  That means if the array fails you still have the original which is stored on an entirely different physical disk.  The second drive in a RAID 1 array does not count as that different disk.  When your RAID array fails, you should restore from your backup.  Sometimes the worst happens, and you need the data from the failed array.  That’s okay, but these instructions are not an excuse to not have backups.  I also can’t guarantee that these instructions will work, and a failure at this stage could damage the RAID array and cause data loss or make it more difficult for a data recovery company to recover data from the drives.

With that out of the way, if you hate data, let’s continue.

Your ShareSpace using a firmware that is Linux-based, and the drives are partitioned and formatted for use in a Linux RAID.  This means putting the drive into a Windows computer will not show any drive letters Windows only understands FAT- and NTFS-formatted drives.  Disk Management will show that the drive has four partitions, but Windows will show the file system as “RAW”.  We’re going to use an operating system called Ubuntu to access the data on a RAID 1 drive.  These instructions are written for Ubuntu 10.04 LTS and higher.

The first thing you’ll need is an Ubuntu Desktop CD.  You can download it for free, and the Ubuntu website gives instructions and software for burning to a CD or creating a bootable USB drive. These CDs can be used to install Ubuntu or to try Ubuntu directly from the CD and that makes them super useful for data recovery, system testing, and so on.  The download and instructions are available here:

Once you have an Ubuntu CD, shut down your ShareSpace and computer.  Remove one drive from your ShareSpace and connect it to your computer using SATA cables.  Then, turn on your computer and boot from the Ubuntu CD.  Check your BIOS settings to make sure your computer is configured to boot from CD.

Once Ubuntu has loaded, click on the button that says “Try Ubuntu”.  After a moment, you will see the Ubuntu desktop.  Because the ShareSpace drive is formatted for use in a RAID array, Ubuntu will ignore it and we will have to mount it manually.  This is very easy to do the second time, but I’m here to guide you through it the first time.  The first thing to know is that Ubuntu doesn’t use drive letters.  Windows provides a drive letter to access file systems on a disk, and Ubuntu lets you “mount” them to a directory.  So the first thing we need to do is find the name of the data partition on the ShareSpace drive.

Go to the System menu, click on Administration, then click on Disk Utility.  From there, you can find your ShareSpace drive on the left, and when you click on it, the device name will be shown in the title bar and on the right side.  In this case, the drive is called /dev/sdb but it might be different on your computer.  You must get the correct name of the device.  We’re going to add a 4 on the end to refer to the data partition, so we’re going to work on /dev/sdb4 in this tutorial.

Finding the device name was the hard part.  Now comes the scary part.  Ubuntu didn’t mount the drive automatically because the drive was part of a RAID array.  So we need to enter a command that tells Ubuntu what drive to mount, how to mount it, and where to mount it.  To enter this command we’ll need a command prompt, so go to the Applications menu, then click on Accessories, and then click on Terminal.  You’ll get a command prompt that looks like this:


That’s where you’ll type in the following command.  If your drive name earlier was /dev/sdc , you’ll substitute /dev/sdc4 instead of /dev/sdb4.  Once you’ve typed it in, press Enter.

sudo mount -t ext3 -o ro /dev/sdb4 /mnt

Hi bspark, sorry to hear you can’t access your files. You need to be sure that you are using the correct name to mount the hard drive. 

“That’s where you’ll type in the following command.  If your drive name earlier was  /dev/sdc , you’ll substitute  /dev/sdc4  instead of /dev/sdb4.  Once you’ve typed it in, press Enter.”

Hi there

Thanks for the reply.

I checked first to see what the drive name was and used…

one drive is /dev/sdc and the other /dev/sde.

also tried  putting both drives in… and tried /dev/sdc  and /dev/sde

Same problem

also tried creating a folder /tmp/mnt

and then tried to mount in that folder… same reply…

Spent many hours and much researching on the web.

Still cant get the drive to mount…

Was hoping that as WD developed the product they can give the direction to recover my data.

Thanks in advance


The saga has been happily sorted out.

By lucky chance I found a link in a post about recovering my data… to  UFS Explorer , a Windows program that locates the SATA Raid Drive … 

(I pulled one of the 2Tb drives out of the dead MyBookworld, and connected it to the SATA connection on the motherboard in my PC. My MyBookworld enclosure died, but the disks were ok).

After Starting the program select the partition that stores the data you want to recover, and simply copy it to another drive… its that easy!
The trial version limits copying files less than 250k. But the registered version copies the loat  Cost  - Euro$ 39.00.

It took about 3 hours to recover and copy about 900Gb of files.

I cannot believe how easy it was to do this… after trying all the Linux commands and hitting brick walls.

As I said to the File Explorer guys… they need to get their program out in Google… I spent nearly 5 agonizing days searching and trying to find a way to recover my precious data… and virtually the only links that came up, related to using Ubuntu Linux to recover the files. 
For Non Linux users, this can be a nightmare, as you are reliant on kind people in the forums assisting you.

I was about to resign myself to the fact that it was gone for good…

All I can say is a Big thank you to UFS Explorer… 

Here’s a link to their web site.

I cannot recommend them highly enough.

WD Support… suggest you look to setting a program link to these guys as well