Rapidly red blinking on drive 1


According to My Cloud Ex2 manual:
“For incompatible drives, the hard drive LEDs blink red rapidly as the unit
powers up”

How can this be possible if the drive is a new Toshiba DT01ACA300 that also is in compatibility list for drives recommended to use?
Any further troubleshooting that can be made?

Thank you for your help
Best regards

I had a single red LED when I first got my WD NAS with two drives, I reseated both drives in the case and problem was solved. First, I turned it completely off and removed power plug to NAS, then I slid the drives partially out, slid them back in until they touched the back, then tilted the case up to finalize the connector alignments, and firmly pressed the drive in to make the connection to back. Problem is gone forever.


After I made the post I decide to upgrade the firware to the last version and the result was different at this time. The Led of the first disk is still red but with steady light. I try all the maneuvers that you suggested but with no success.
I dont belive that I have a brand new Toshiba drive faulty.

It is hard to believe you have a faulty new hard drive, although I once received two faulty ones in a row! Third one was OK. Don’t remember the brand, but it was not WD.
Anyway, if you are mixing brands in the EX2, even if they are supposed to be compatible, that possibly could cause an issue. Contact WD support at this time.

It is a normal behaviour, if you installed a new unformatted disk or disk with a file system, which is not supported by EX2.
You have to choose the RAID mode (in the dashboard) and then format the disk.

Makes sense to me. This is probably all laid out in the complete user manual, too. Glad I got a dual drive NAS all set up to get going.

Its also make sense to me. Since I dont have any desktop or a case to install the new hard drive I can not format it.
I tried what Felix_The_Cat suggest but i dont work because the second new and supposedly “faulty” is not recognize as a volume in the dashbord so I can not format it from there. The only information that come up in the dashboard regarding Volume_2 is that is in bad shape and I cant make any action to it. If I try to change the raid mode only JBOD appear because I only have one disk. I need to find a Desktop to format the disk. It only support ext4?

You can try to remove another (working) disk, and operate only with this new disk.

I tried what you suggest but since the EX2 is “faulty” the dashboard ask me to put a drive to proceed in the main page.
I’ll try to format the disk in a desktop