Rant! The perpetual Scans forever and ever and ever - frustrated with road rage type anger


Was just pointing out the potential. You dont know how many support calls I fielded working at NetApp about thin provisioned LUNs serving virtual exchange servers, and the SUPER CONVENIENT background defragmenter doing its thing making the thin provisioned LUN not be so thin anymore, all suddenly. (In big deployments, where they have a dozen or so virtual servers all living on thin LUNs using VMWare or some other virtualizer, all living crammed together on a barely sufficient storage controller— having them all suddenly decide that they need their full allocation, all at once, all at the same time— makes the virtual server admins have a heart attack and call support frantically.)

You try explaining to a customer that there is nothing wrong with the storage controller at all, and that their virtual server deployment(s) is(are) responsible. Try doing it when the admin gets paid way more than you do, and proudly knows it, and refuses to listen to you. It gets even better when they expect you to be able to get corporate to change their advertising to contain a caveat about windows background defragmentation service when they proudly proclaim the virtues of thin provisioned LUNs.

I’m still a bit sore about it actually. Just be wary of thin provisioned LUNs unless you know EXACTLY what you are doing. :stuck_out_tongue:



I posted at the beginning of the year I purchased a Qnap TVS-673 NAS and was leaving WD MyCloud behind. I can certainly tell you I haven’t regretted the purchase. Besides the apps that are available, raid configuration options, thick or thin provisioning, etc., Qnap is on top of the firmware security updates (along with features).

So far, there has been at least 1 firmware update a month … and a patch if there is a security hole that needs patching immediately. Their forum, like this one, is a user based forum with tons of help and some extremely experienced users.

Although it is unfair to compare a Qnap to a WD MyCloud based on price and usability, you will not regret purchasing a Qnap no matter what series you choose. I use my 2 MyClouds as backups to other Backup devices, so I haven’t stopped using the MyClouds … just reallocated their purpose.

All the best, :slight_smile:


There is always something wrong, but the problem is usually between the chair and the keyboard. It’s commonly called an ID10T error.


Hi guys,

Please be respectful on the community per our TOS. I’m not going to flag this one, but it’s a borderline case.


And here I thought it was an intermittent connection between the keyboard and the outside world.


yes guys please be respectful of me.

it seems that I’m a borderline case… :stuck_out_tongue:


Borderline case? Seriously, somebody needs to get a sense of humor. That joke has been circulating among the tech circles for more than 30 years, or at least that’s how long I have been aware of it. Now if I were to call a specific person, you for example, an id10t… now that would be different.

Perhaps this is simply the inevitable result of this insane politically correct culture we live in today, where people are hyper-sensitive about literally everything imaginable. Regardless, anyone who has worked with end users knows there is some truth to it, joke or not.

Flag me if you wish, frankly… I don’t care.


I know it has been- nonetheless, if someone were to get offended and complain (it wouldn’t be the first time someone complained over something you or I might take as a joke) I’d be forced to take action despite your good intentions (as you said, that’s the crazy world we live in today) which is why I gave you a friendly warning to be careful.


It’s inevitable, so I never worry too much about it.


The straw that finally broke me was all the work that I put into separating my data into non-scanable files; all my photos into a 3TB My Book Duo and backups into another 3TB My Book Duo, did diddly squat on the 2TB EX2 that had no files in it except for a 1TB iSCSI partition, was on all night with its fans on. In addition, both of my My Books had the media switch turned on with one My Book unmounted.

Like “say what?”

These backup units have been untouched for days and "how did both of my My Books suddenly have the Media Switch turned on?

I re-booted the device by doing it the long way, unconnected both USB drives, Hibernate the EX2, re-power up the EX2, reconnect both USB drives, the My Books were blinking rapidly showing that they were being SCANNED!

Remember folks, I live alone and having my My Book UN-Mounted is strange. After boot-up, the drive (one) re-mounted without any problems.

The media switch being turned on? I don’t understand. I’m guessing that I must have accessed it by my iPhone app, which then triggers the scan process. Just to be clear here, there are absolutely no files on this 2TB ex2 that would trigger a cloud access scanning and I have turned off all Cloud access on ALL my Cloud drives rendering them useless as a Cloud device simply for the fact that I hate the scans.

It is unacceptable especially after the latest cloud update is about privacy.

Who is accessing my data and why?

Lastly as you can see my 8TB cloud light is red. That is a Microsoft like ■■■■■ move where they tell you that your drive is full even if you have 400GB of free space.

Yup time to move on…

click… click… click… click…click… click… click… click…click… click… click… click…
. like a marching band… on my 8TB single Bay My Cloud.


so mea cupa :rage:

The loud clicking of the drives is apparently the design of the helium filled 10TB gold drives or at least they were clicking loudly on the initial startup of my brand new QNAP. I’m not sure if they normally click every few seconds, but right now QNAP is formatting them and the rattling sound is about the same volume as my EX2.

Found this on youtube regarding the loud clicking noises from the 10TB.

Not happy but I guess I have to say…

c’est la vie.

I’m not sure if anyone cares about my findings, but apparently unlike the old days of Windows server where you can allocate portions of the hard drive for a certain raid type and the remainider to another type, QNAP does not allow this. For example 2x10TB with 2X8TB raid 5 would give you 21TB usable (that is because the 8TB is really 7TB in size, thus 3x7 = 21TB with 2TB left over on each of the 10TB drives of which I was planning to create a 2TB mirror. Except QNAP doesn’t allow you to do that. All you get is 21TB total pool.

So what this means that because of my OCD where everything must balance, I’ll need to spend another $1k on another pair of 10TB hard drives to balance the raid 5 to 28TB.

Anyways I am at a loss on what to do…


So I’m committed.

I’m curbing my OCD by closing my mind’s eye and just using the QNAP as-is with 21TB Raid 5. Once all the data has migrated, which should take about a week, i’ll reset all my clouds and my books duo and just sell them off on Craigs. Replacing all 3xEX2/2xMyBooks with one QNAP :stuck_out_tongue:

So this is probably good-bye… and thanks for all the memories. Not looking back…


I’d say enjoy the peace and quite. But as it seems you are a click magnet. Not sure that is going to happen.

PS I did not spell click incorrectly.


you spelt quiet wrong :stuck_out_tongue:

anyways QNAP is a different marriage that I am much more incline to forgive than the decade old marriage to the “my cloud hussy” :stuck_out_tongue:


Yes. I have a problem of dyslexia of the keyboard at times. But again enjoy the extra free time.


@Great_Scottt, please pass this upwards to the great gods of WD.

So easy… just need this panel (see below)l and there would be no complaints!! It is exactly what I had asked for a half decade ago. It even has schedules for when the scans occurs.

The reason that I can forgive the clicking of a QNAP is that the panel is telling me what QNAP is doing. For 10 hours of gurgling, sounding much like my coffee percolator, my QNAP has been synchronizing my Raid. From my experience of the 2-bay TS-231P, once the synchronizing of my Raid is done, I heard no further clicking other than when data is being transferred TO or From the NAS.

Although I knew what the EX2 was doing, there was no method of stopping the scans other than SSH’ing into the device OR turning off Cloud Access of which I DO WANT Cloud Access since of course I want file access from outside my home.

I had wanted just the switch to

  • turn off the scans
  • schedule the scans
  • scan now and never scan again (so I have some thumbnails and no new thumbnails)

I had suspected that the clicking every second is from the “init script” checking if the user has added or deleted any files by comparing the volume size. I know WD does this because of this exact same loop in the sleep script on your older models and by eliminating the check on the older model the clicking stopped. I could not make the same changes on the newer models because this has been incorporated into the “init” script that controls the whole NAS right from the beginning. Killing init, restarts the NAS (I tried).

So when the “My Cloud” is awake, it goes click, click, click, click… and in a quiet room it is akin of listening to a ticking clock.

Anyways I found this panel on the QNAP this morning and I thought “if only” and I don’t know why your WD engineers or perhaps WD themselves, are so stubborn in NOT implementing this. It is a simple request.

TURN OFF the ■■■■■ ■■■■■ SCANS!!!

So here it is… your competitors has it…

and after you click on “Deactivate Media Library” you get



Goodbye WD!! Hello QNAP!!

Well I’m still using WD 10TB Gold hard drives and two My Clouds for backup so I haven’t eliminated everything WD in my life. The EX2’s have been boxed up sans disks. Will be boxing up the last EX2 this week and boxing up the two My Book Duos. They are all going on Craigslist.


I think you make the mistake that someone at WD actually knows how to program the My Cloud. I have little confidence that WD could create this panel. We know from past experience that the only thing support knows how to do is 40 second resets, reinstall firmware or RMA the My Cloud.


I did make the mistake.

The feeling of frustrations is because I feel so ineffectual and that is an even bigger mistake because for years I’ve been posting up siding with WD to help users to get over their mistake in buying WD. Telling WD customers that if they only did this (ssh’ing into the device or turning off Cloud Access) that they would be happy… to find that it was all a lie, I was fooling them and I was fooling myself.

Turning off Cloud Access doesn’t make me happy because I would have no Cloud access on a Cloud access device but hey, at least it isn’t scanning. I remember that day very fondly when WD announced that they did give us a switch to turn off scanning by turning off Cloud Access and I thought, hey “maybe WD does care”… hah!

SSH’ing into the device and killing the jobs that scans, doesn’t make me happy, because I would rush to SSH into the device after each boot-up to stop the scans otherwise, back in the days, the device would be so overwhelmed by the scans that it would drop off the network. Been doing this for years and frankly, I’m tired of it.

I do feel so ineffectual :frowning: because I would study the script files hoping to find that one piece of code that can kill or run that would solve everything including rewriting monitorio.sh. A few weeks ago, I actually went through every job and methodically killed each one including “init” to see if the clicking would stop. Why am I doing this? Why isn’t WD doing anything? Does WD really think so little of their customers?

Are we simply whiners? Yup… I’m done… I’m not a whiner…

If only…



Big white block of ugly form factor :stuck_out_tongue:

The book cover now has book cover topping… yes I do have too much time on my hands…


Since you now own a QNAP, the following article may be of interest to you. I strongly advise that you take it seriously.