Randomly can't access to the Network Shares menu

This is so frustrating.

Sometimes i can access the shared folders, sometimes i don’t, and the thing that bugs me most is that i cannot understand what decides if it’s gonna work or not.

For example last night it wasn’t working. I was sure it was about the _MSBROWSE_ thing. So I checked who was the master: my father’s laptop. I disconnected it and checked again: router. But, even after rebooting the WDTV, it wasn’t working.

This morning everything is working just fine. But there’s no substantial change from last night, infact the master browser tag is still on the router.

This is my network description:

  • Router

  • WDTV Live (fw: 1.06.43_V) (via ethernet)

  • My PC, Win7 (via ethernet)

  • Home server, Ubuntu Server (via ethernet)

-  Brother’s PC, Win7 (via ethernet)

  • Father’s laptop, Win7 (via ethernet or wifi, depends on the position)

  • Random number (maximum of 4) of android devices (via wifi)

My PC and the home server are connected though a switch.

Except the android ones (which i didn’t check) , all the devices are in the same workgroup (WORKGROUP).

The folders are shared by the home server, via samba, and i can access them correctly though any other device.

I love this little box, but i’m sure it hates me.


Try setting a static IP on the media player.

1 Like

HDKnows wrote:




Try setting a static IP on the media player.

It seems that setting a static ip fixed the problem. Or at least, i’ve tried 3-4 times in the past week, and i’ve always been able to connect to the network shares. I’ll report back again after some time.

But, in case this really fixed the problem, may i ask you why it worked? I mean, what’s the “science” behind this? What’s wrong with the dynamic ip?
Thanks again for the anwser and for the solution.

Ok, it definitely fixed the problem, thanks mate.

Still curious about why it worked, though.