Raid0 Error but no error with no Raid


#1

I currently have raid0 with two 750gb WD drive working fine for many months, recently I bought a 1tb WD drive and added that with a 1tb drive from a returned RMA to make another Raid0

If I run both 1TB drive as JBod (single drives no in a raid) they operate fine, no errors.

If I run both 1TB drive as Raid0 after a short time I get sector errors. (no SMART errors, just error logged in the FAT)

HDD1 is :

Model: WDC WD10EARS-22Y5B1

Serial: WD-WCAV5D255317

Firmware: 80.00A80

Physical Sector Size: 3072bytes

Logical Sector Size: 512bytes

Size: 953,869mb

64mb Cache

HDD2 is :

Model: WDC WD10EARS-00MVWB0

Serial: WD-WMAZA0140441

Firmware: 50.0AB50

Physical Sector Size: 512bytes

Logical Sector Size: 512bytes

Size: 953,869mb

64mb Cache

The Firmware and Physical Sector Size are different. When formatting the drive in Windows you can only modify the Logical Sector Size, the Physical Sector Size seems to be preset in the drive.

Even those these two drives are with-in a week of each other when recieved they have those two differences. When both are setup in Raid0 the drive with the 3072byte Physical Sector Size gets sector errors but the drive with the 512bytes Physical Sector Size doesn’t.

 On another computer here I have six 1TB drives working without issues as raid0 and raid5 (2 virtual drives on a single 6 drive array), 4 drives purchased at the same time, 2 purchased a week after 1TB drives were released (but different from eachother cause they were from different batches), so much older, they all have Physical Sector Sizes of 512bytes and also the older drives have smaller caches. So the age of each drive doesn’t seem to be an issue on that computer.

How can I make the Physical Sector Size 512bytes.

and

Are these two drives just not similar enough to operate as Raid0 ?


#2

WD Customer Service informed me the two drives are different models and not compatable in Raid with eachother. Both drives now as single drives and test so far are good with no sector errors.


#3

I guess you didn’t need the pictures after all.