RAID rebuild taking days/weeks/months/not working?

I had a similar issue last week.  I had my EX4 configured with 2 x 3TB drives in a RAID-1 mirrored volume.  I backed everything up and added a 3rd 3TB drive.  I went through the wizard to change the RAID mode from RAID-1 to RAID-5 and migrate the data.

After about 5 to 10 minutes, the progress indicator went from 0 to 5%.  It didn’t change after an hour, so I created a support ticket with WD.  After failing to receive a response from WD support after a day, I called.  (After 25 hours, the progress had gone from 5% to 6% and the progress indicator was estimating more than 30 days.)  WD support informed me that this was normal, but that the process would not take 30 days.  They estimated 3 days.  Amazingly, they were right.  After 73 hours, the process completed.  The next step of resizing the volume from 3 TB to 6TB took another couple of hours.

The information above regarding adjusting the throttling configuration is brilliant.  I wish I’d seen it prior to my experience.

How to do you log into the decive? I logged into the dashboard but don’t know where to enter that text. Please help!

I do apologize, but this is my first time using the board,

Can you assist me with logging into my device to change the settings, I logged into my dashboard and don’t know where to go please advise.


go to users tab → admin

and you should be able to change all the things on need there

I have a default raid5 made up with 2+2+2+2 terabyte disk.

It is around 56% full.

I removed and reinserted disk 3 for a test in a matter of seconds and now is automatically rebuilding the volume 1.

according to /proc/mdstat

md1 : active raid5 sde2[2] sda2[0] sdd2[3] sdb2[1]

      5847956928 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/3] [UU_U]

      [>…]  recovery =  4.7% (91982336/1949318976) finish=945.3min speed=32743K/sec

can i access the data during the rebuild?

It seems i can not see the smb or aftp shares in the meanwhile :frowning:

For example from dashboard → shares → public everything is greyed out except “oplocks”

the only user is “admin”

After the end of rebuild everything is back to normality.

Isn’t it possible to keep access to the samba shares during the raid5 volume rebuild ?

Can I expect to have a full data access after my WD EX4 rebuilt due to accidentaly power failure?


Thank you for your excellent advice. That is going to speed things up considerably. Once the sync is complete, do you recommend reducing the speed limit back to the original setting? If yes, what parameter would you use? If no, do you think the higher speed raid syncing will impact user upload/download performance?

Thanks for the assistance.

James_TNHD wrote:

I’ve got news for you John1000,  Recently I whent through the same problem being stuck at the rebuilding status for countless hours and well I kinda got tired of waiting for it and decided to speed things up. 

Now I don’t know why WD would cap the Rebuild speed to 1031K/sec but if you wanna speed things up all you have to do is log into your device and type in:

sysctl -w

after that go ahead and type


cat /proc/mdstat


and you’ll see some BIG difference in speed.


~ # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid1 sdc2[0] sdd2[1]
3902822264 blocks super 1.0 [2/2] [UU]
[====>…] resync = 22.2% (869768832/3902822264) finish=792.1min speed=63812K/sec

md0 : active raid1 sdd1[3] sdc1[2] sdb1[1] sda1[0]
2097088 blocks [4/4] [UUUU]

unused devices:


Just make sure not to do anything else with the device and disable all downloading or sync services while you do this process as this will degrade the speed for the rebuild. 




Quote? I don’t need no stinkin quote…


Thanks that command (sysctl -w totally helped me out

My rebuild was at 59407 minutes then dropped to 13859 !!!

Then few mins later dropped to 1396 (under a day)  WOW



Can anyone please help me?

I have read where many EX4 users have experienced long rebuild of EX4.

Just over a week ago, I purchased a new EX4 24tb and set it to RAID 10.

Copied 8tb of files to it and all was going well. While still copying the last 2 tb, as fate would have it… a sudden power failure in the area shut down the EX4 …mid copying.

Upon startup, it bagan a rebuild of volume 1.

7days have now passed, and the rebuild is still showing 9999 minutes and has completed only 3% so far.

It has not stalled and continues to rebuild files… but at this rate… 3% in 7 days… it will take around 240 days to complete the rebuild.

I have read on the community boards, that I can go to “admin - and change the things there”… but I looked there, and everywhere in the dashboard… but cannot see anywhere how to do this.

Can anyone please steer me in the right direction, please? 

I am using a Windows 8.1 computer connected to the same network as the EX4.

Many thanks and best regards



I ve been trying for hours to find a way to enter the text    sysctl -w     as mentioned on the forum but I can’t find the right place to enter it. I noticed that others cannot find it either, even though we checked under    users/admin as prompted.   There was nothing there to enter any text.

Any help would be appreciated

best regards


Hi Guys,

I understand, I was new to all this not too long ago…

You will need to enter these commands via a command line ssh… BUT be very careful because once you are in there, you CAN do damage unless you are very careful as you are going “under the covers” so to speak.

You will need to log into your portal, then go to Settings.  Select Network (on the left) and enable SSH.  You may also need to set a password.

Once you have done that you can start a terminal session and log into the device itself… on my mac, I connect using Terminal, and then type “ssh @” then hit enter, and it will prompt you for a password.

Once you are logged in you can enter the commands as stated earlier in this post.

Hope this helps…

Hi folks - I know this is an older thread but I’m having a similar problem with my My Cloud Mirror 8TB though the suggestion above for raising the speed limit didn’t seem to help. In my case it’s running around ~64K/sec (I’ve seen as low as 40K/sec and the highest about 200K/sec). I just posted this thread in the Mirror forum but thought I’d cross-post in hopes that any of you had a suggestion for a way to disable the RAID rebuild process.

No clue why but my WD Mycloud 8TB had a red light on it.

I logged into dashboard and it stated raid was rebuilding.

Why did it start rebuilding? any thoughts?

Anyways, I tried the above mentioned command. It doesn’t seem to be making any impact in the time.

Btw the above mentioned command: sysctl -w → I issued via terminal by doing an ssh into the WD drive (ip Is that the correct place to input this command? If I put that IP into safari, the WD dashboard comes up, so i assume i have the correct IP to use in my ssh command.


Dear Tony, thank you for your suggestion. I have added 2 x 4Tb to my EX4100 that already had 2 x 4Tb RAID 1, now I migrated to RAID 5 but it is only at 8% after three days. Would your solution work for me as well?

cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid5 sda2[3] sdb2[2] sdd2[1] sdc2[0]
3902822208 blocks super 1.0 level 5, 64k chunk, algorithm 2 [4/4] [UUUU]
[>…] reshape = 3.9% (155776000/3902822208) finish=58990.0min speed=1058K/sec

md0 : active raid1 sda1[3] sdb1[2] sdd1[1] sdc1[0]
2097140 blocks super 1.0 [4/4] [UUUU]
bitmap: 0/1 pages [0KB], 128KB chunk

Thank you.

I used this technique and increased the minimum speed limit to 200000 then to 300000 then to 400000 and back down to 300000 because that limit gave the best performance. It took about 36 hours total to take 3.82TB from JBOD on a single 4TB drive to RAID 5 with 4TB/6TB/6TB.

Ok this is WIERD. I tried
sysctl -w

I got back invalid argument BUT the darn thing still sped up! The time it was going to take was slowly increasing. I was up to 100 days after about an hour in. That whole hour it stayed at 0.00%. After I entered the command it almost immediately dropped to 1355 minutes and it continues to decrease. It dropped to 1259 minutes well I was typing this post. I don’t know what happened. Perhaps the progress was just wrong. Maybe the setting did something despite the error. I’m just glad I don’t have to restore everything manually because at the rate it was going it was never going to finish.

PS: The NAS was not busy so far as I could tell because resource usage was very low. Just to be safe I turned off all the apps. I also removed mappings from my PC.

Amazing technique. Thanks for your suggestion. Works well.

I’m having the same problem with my EX2. I login via ssh and I check the drive to see this:

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid1 sda2[0] sdb2[1]
3902822264 blocks super 1.0 [2/2] [UU]
[==========>…] resync = 53.6% (2093466368/3902822264) finish=47200.9min speed=638K/sec
bitmap: 1/1 pages [32KB], 262144KB chunk

md0 : active raid1 sdb1[1] sda1[0]
2097088 blocks [2/2] [UU]
bitmap: 1/16 pages [32KB], 8KB chunk

unused devices:

I tried speeding up the drive using sysctl -w but it didn’t speed anything up. At the current rate, it’s going to take a month.

You have to turn on SSH in the system network settings.