RAID 5 slow down

I built a RAID 5 set on my Asus Core2 P45 Express/ICH10R motherboard just over 2 years ago. I didn’t know it at the time, but the three 500GB WD Caviar Blacks I bought for the job “aren’t designed for RAID 5”. Nonetheless, it all worked beyond my expectations. Here’s the benchmark it produced:

Not bad, eh?

Everything worked fine for over 12 months, then one day I got a warning symbol in the Intel RST tray icon. One of the drives had failed. WD happily replaced the drive for me, and the initial contact made sure that the replacement would work okay with RAID, as apparently, some of the Caviar Blacks do not. The array rebuilt okay, and I carried on smugly, knowing that RAID 5 is the proberbial dog’s wotsits.

Fast forward a year and a bit, and after struggling with some heavy duty bulk file manipulations, I start to look under the bonnet. I benchmarked the drives again. The boot drive was exactly the same. The RAID set, however, was not:

Whoah! That’s quite a big drop in performance. Still not too shabby, but not nearly as impressive.

So, I start to think what has changed in the 27 months since it was first benchmarked…

  1. I overclocked the motherboard by 33%.

  2. I have replaced one of the array drives (see above).

  3. I replaced the graphics card with a faster one.

  4. A lot of software and drivers have come and gone or been updated, including the storage drivers.

  5. I haven’t changed the operating system (W7-64b), nor have I updated the BIOS.

  6. We had a power cut a month ago, and the RAID had to check itself for a while before being ok (sorry, I can’t remember the lingo).

Yesterday, I “Verified” the array with Intel RST. Last I looked it had found 2 corrected errors, but I could find no log when it finished.

This morning, I reversed the overclocking, but it had no effect on the benchmark.

There is nothing in the RAID BIOS I can tweak.

I doubt the graphics card will be a factor, and I don’t know how to go about reverting the storage drivers, or how far back to go, or if it would make any difference.

Note that the replacement drive has a slightly different model number, but I always assumed this was okay:

Originals: WD5001AALS-00E3A0 (firmware 05.01D05)

Replacement: WD5001AALS-00L3B2 (firmware 01.03B01)

(according to Intel RST).

Phew. That’s a lot of information. Thanks for reading this far!

Any ideas?

Yours hopefully.


Even the figures look mathematically significant: Max speed 25% drop; Min speed 50% drop.

It looks like I’m going to have to break up the array. Western Digital isn’t going to support three Blacks in a RAID5 set. I wish I’d known before I started.

I have no idea if the slow-down happened after they replaced the faulty drive, or if it’s happened since. My motherboard is three years old, so I’m guessing I won’t get any support from Asus either.

I’m knackered.

Maybe I’ll take out the replacement drive and turn the others into RAID 0/1.

Shame. I can’t find anything online which helps with diagnosis, and the Intel RAID BIOS and application are minimal. I thought someone might have had a simple explanation.

Mystery solved! I split the RAID up and tested individually. All drives passed, but …

HD1 (replacement):



Got three replacement drives from WD yesterday. Faster in the first half, slower in the second. Slower access time. Bigger burst rate. Averages out about the same. A fair result.





Those 2010 500GB Caviar Blacks were fearsome drives! I read somewhere that it was guessed that these were actually 1TB drives which only used the first half of the platter. That would certainly explain the flat speed curve.