Raid 0 drives getting stuck attempting to go to sleep

I just started having this problem several days ago, possibly after installing the latest Windows 7 64 motherboard drivers, windows update and IRST app.

I have an SSD running windows, a 4tb backup drive and 2 western digital black drives in raid 0

I have windows set to turn off the hard disks after 20mins, at this time the hard drive light goes solid red, with the side off the case I can hear and feel both raid 0 drives making a repetitive clicking noise, when I open one of the partitions in windows it wakes the drives up and they behave normally, my 4tb drive goes to sleep without issue.

Could one of the raid drives fail in such a way that it’s unable to sleep?

Edit: I just tried to restore my computer to an earlier time and after reboot it said it couldn’t do it because of a problem with a recent windows update and to choose another restore point but incredibly incompetent Microsoft’s Windows deleted all the restore points after it had the problem, cut of your head because your toe’s broken kind of logic!

Edit2: I notice that the drives make a different repeating noise at shutdown, this noise repeats till the system turns off, all the mechanical drives in the system make this noise.

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

I’ve solved the problem, it was the recently installed Intel IRST15.7.1.1015_RS2_20170718 driver from Asus, I installed the previous driver release and the problem is gone, my drives sleep and shut down normally.

I reinstalled the driver a few times to make sure but that driver is just bad, I have notified Asus and made a post on Intel forums about it.

Hi Wizzzzard ,

We appreciate your feedback and glad that issue has resolved now.

Thanks!