Quicklook Error Domain 44820

How can I open a password protected Excel or Word file on my iPhone My Cloud App?

If I want to open a password protected file I get the message:

The operation couldn’t be completed. (QuickLookErrorDomain error 44820)

Looks like that error message is a common complaint going back a few years with Microsoft products that use password protection on the files under Apple iOS.


Does the same error message happen if you download the password protected Excel or Word file to your local iOS device and then open it within an Excel or Word viewer/reader app?

Thank you for you’re reaction.

No, when I open it on my other iOS devices I don’t get the error. I get the error only on my iPhone.

I have also search on google and try to open the password protected Excel or Word file in the Excel app for my iPhone and I can open the file.
Also in the iCloud Drive app and Dropbox app I can open the password protected file.

It is only in the My Cloud app I can’t open the password protected file. Also in the My Cloud app I can’t open the file in Dropbox (is connected with My Cloud)

Did anyone ever figure this out? there are several postings but none appear to have been solved.

Hello Poppins,

I have called to WD and the problem is solved. Thank you for you’re message.

I suspect poppins was hoping you might be able to supply the solution you found…

I will try to explain it in English, and I don’t have the WD Cloud anymore so I don’t know exactly.

You need an Excell and Word app on you’re iPhone.

If you want to open the document in the Mycloud app you see on the right side above the share icon.
You click on the icon and I think you can choose “Open in” than you select Excel or Word, the document opens in Excel and now you can type you’re password for the document.

I hope that I have helped you a little bit with this.