Quick Formatter error when attempting to format my WD My Passport USB 3.0

I recently received my WD My Passport USB 3.0 portable external drive and attempted to format it using the Quick Formatter tool and received an error stating that the drive was currently in use and to close all applications. I rebooted my laptop and proceeded to attempt once more to format it right after the reboot , no applications were opened, and i recieved the same error (i am using a PC running Windows 7 OS). I then attempted to try to use my desktop and siblings laptop to see if my laptop was the cause of the issue, but found the same error occuring on the other two PCs. 

I would like to ask two main questions:

  1. Is it nessecary to format the drive? i.e what are the benefits/disadvantages of formatting or not formatting it?

  2. What is causing this error and how can i rectify it so i will be able to format my external drive?

having the same issue, im using a mac pro

If you bought the correct drive for your Windows or Mac you shouldn’t need to reformat it unless you are changing the format type such as from NTFS to FAT32… Windows and Mac do use different formats.