Question about My Cloud remote access and OS 5

Hi! So far, our OS 5 upgrade has worked fine. Our My Cloud NAS updates its firmware, every so often, and I can access the drive through website and via GoodSync (including remotely). When I logged into the website, I saw the folders my user has access to and I wanted to move a file from one folder to the “Public” folder. From what I can see, I’m able to move files only within the current folder (including sub-folders of the current folder).

Is it correct that I can’t move a file from one folder to another “peer” level folder?

Thanks in advance!

See the following WD Support Knowledge Base Article for more information.

My Cloud OS 5: Manage Files on Web and Mobile App

Managing content using the My Cloud OS 5 Client apps have the following limitations.

Thanks for the information!

I successfully upgraded to OS5…locally everything works as before, but the CPU of the NAS is heavily loaded. My main concern is that many folders are missing when I access them remotely, but exist locally.

You may need to wait a while for the “indexing” feature in OS5 to finish for all the data to show up when accessing the My Cloud remotely.

1 Like

Well…I made a few dreadful discoveries about the new remote access interface OS5…Create a folder called “WD SmartWare.swstor” in any Share on your NAS…Load some files locally to that folder and tell me if they show up remotly…Guess what happens.

I came to the conclusion that WD is “manipulating” the remote access so you can only see what they want.

That’s interesting. I haven’t had any issues with files appearing remotely but then again, I’m not using folder names similar to the one you posted above. I’m currently working through a GoodSync issue (with GoodSync support) where the GoodSync for NAS server saves files and directories, on the NAS, with incorrect permissions. I haven’t spent this much time accessing our NAS via ssh before and I’m learning quite a bit! :slight_smile:

Getting back to your issue, have you noticed files not appearing remotely when NOT using folder names that contain “WD SmartWare”?


All other files with folders different from “WD SmartWare.swstor” show up remotly, despite some delays when you delete them.

Regarding GoodSync I’m trying to understand it, but I feel it’s rather “convoluted”, not transparent and GoodSync Explorer lacks privacy completely!. You have access to the entire NAS despite permissions of the Shares and users. The same behaviour occurs in a Synology.

That’s interesting about GoodSync as that hasn’t been my experience. So, I installed “GoodSync for NAS” on the MyCloud NAS, itself. I then setup the GoodSync explorer to view the NAS remotely. During the setup of GoodSync for NAS, I had to define which users were allowed access and which directory they would be connected to when logged in. Doing this, I couldn’t see any other shares or anything. It was only when I granted access to the directory where all the shares are that a user could see “more stuff”. So, maybe we have GoodSync configured differently.

Right now, I have GoodSync synchronizing files and folders from a remote Windows 10 system to our MyCloud NAS. Some of those files and folders can also be viewed by users locally connected to the NAS. That’s working mostly well and is almost entirely automated (with the exception of the permission issue I mentioned above). I think once that issue is resolved, we’re “good to go” with what we need.

I’m not happy about having to use GoodSync and I’m trying to cope with it as best as I can.

You mentioned Synology above. Are you saying when you connect to your Synology NAS using the GoodSync explorer, you can see everything?


As I had said, I think GoodSync is complex, so I probably misconfigured some setting. I only tried GoodSync with different user accounts on the Synology. On the WDMyCloud I only used one user.