Question About Expanding 2TB Model


#1

Lots of questions… bear with me!

I see that they go up to 8TB now.  I assume this is a function of the new larger hard drives that are available and that I should be able to upgrade mine to 6TB by adding (2) 2TB drives to the (2) 1TB it came with.  Can anyone confirm this?

Is there a list of compatible drives to expand the 2TB model?

I am running RAID 1 for full redundancy with the first two drives.  Am I stuck with RAID 1 or can I convert to RAID 5 without redoing from scratch?  Does having different sized hard drives effect the ability to use RAID 5?

Thanks!


#2

I too have a question about expanding a 2TB Sharespace.

I have 2 extra WD Black 1TB SATA drives that I would like to add and want to know if I can just install them in the two open slots?

Will the unit automatically add and format them to the RAID array if I change it to RAID 5?

Thanks for any enlightenment.


#3

@ dudemanbubba

I asked WDC support about supported drives a while back - and there does not appear to be a specfic list. What is specific is that the drives should be WDC. Making that choice ensures that WDC Technical Support will talk to you if you have an issue.

Personally, I  just added a couple more 1TB WDC Caviar GP drives and all was perfectly fine. They use the GP drives by default so that should be a safe bet.

re: the RAID. Well now, good new/bad news depending on what you really want at the end.

Firstly, when working in the RAID world the smallest physical disk typically dictates how much disk space is allowed to be used on larger drives. So if you have 2x2TB & 1x1TB, then to use then in anything other than RAID0 will mean that you effectively have 4x1TB available drive space per drive. Still with me?

If you want to go RAID5 (as I have and would strongly recommend it) - then you would be able to - but the RAID array will be built as 4x1TB drives. You won’t get the benefit of the 2TB drives additional storage capacity.

As mentioned, I went for 4x 1TB drives in a RAID5 and that has given me about 2.7TB usable space.

Now, if you don want RAID5, you have another option, dual RAID1 mirrors. so you can keep your existing RAID1, drop in the other disks and create another RAID1 usable pair. It’s fine doing this but I wanted the simplicity that RAID5 gave me and was not overally concerned about performance - bearing in mind it is networked attached storage after all.

If I were you - I’d back up what you got… (you have got a back mechanism havent you? :slight_smile: )

Go RAID5 and leave it to tick over of its own accord…

Cheers


#4

@Havatar

Ok so you can’t create a RAID5 array until you’ve inserted the drives - so depending on how it is currently configured will dictate what options you have.

If you’re in the enviable position of starting from scratch with no data on the drives - then juse drop them in and go through the admin interface to ensure that RAID5 is selected.

@all - do be warned on speed of RAID building - as an example, my 4x1TB RAID5 array has previously taken over 18 hours to complete building - and that was without any network activity… That’s normal by the way - RAID5 takes ages to build on any system as it is dependant upon the performance of the underlying hardware.

Cheers


#5

You are probably suggesting the RAID 5 to save funds and only buy (2) 1TB to get 2.7 total storage with RAID 5.

The “easiest” would be the RAID 1.  If I drop two 2TB drives in as an additional RAID 1 pair will I end up with 3TB total usable storage - (2) 1TB from the initial and (2) 2TB newly added?

Removing everything and starting over would be a big PIA.


#6

I did not expect such a fast response. Thank you. I’ll have to bite the bullet on the data and back it up to a 500GB USB drive. Luckily I haven’t loaded the WD up with all the data yet.

Thanks again, you were a big help.


#7

@dudemanbubba

Yes - my thoughts were a combination of cost versus actual net capacity gain versus ongoing admin…

You’re right, keeping the current RAID1 array and creating a new one with the new pair of disks is the simplest immediate option. You’ll find that going the RAID5 route will give you the longer term reduced administration of the data set - as simply put - with RAID5, all the data is on the one volume versus the 2x RAID1 arrays.

For the sake of a few hundred MBs - my money stays with the RAID5 option… :slight_smile: - but then I’m not in your position with a shed load of data already on the SSpace…

@ALL - *Take note* - before adding drives to an existing system then I recommend turning off the option 

Extend Span
Mode Auto Extend

This can be found in the admin menu - System/Advanced - and set it to manual before you add any drives. This will save considerable time as it will prevent the SSpace automatically adding your new drives to a span configuration - which you would then have to wait to complete before breaking it to become a RAID5 config…

Cheers


#8

@Havatar

No worries about the quick response… It doesn’t always happen - it just depends on who’s on line and when and who can help… :slight_smile:

As a thought, it will be quicker for the SSpace to do the backup to USB for you - rather than initiate a network copy via PC. I don;t know how you have the SSpace set up or what is on your external drive - but you may wish to use the SSpace backup to USB function that I believe there is (at least I think there is an option - not used it myself)

Good luck with your RAID rebuild!

Cheers


#9

Going to bite the bullet and redo with RAID 5.  Started my data transfer tonight… about 650 GB worth.  Probably be done some time tomorrow night.  Then the drive install and 18 hours of reformat…  Then another day of transferring back!

Yeah!

I hope the performance of RAID 5 is much better!


#10

Just got a reply to my question through the tech support web services.  They said that my 2TB ShareSpace will only be expandable with 1TB drives.  That is different from everything else I have read.  The following is the reply:

I apologize for the delay, your drive can be upgrade up to 4 TB only, two drives of 1 TB, the enclosure will not recognize drive of bigger size.

Oh well… looks like I decided on the best direction anyway.


#11

For anyone who knows the process… I know it is supposed to take a while for the RAID 5 to initialize with the (4) 1TB drives.  When I click on the status from the Volume Management screen it tells me that it is “recovering” (its be 12 hours and its at 80%).  I had (2) TB originally and added two more drives yesterday.  Is it trying to recover my data or is “recovering” just what it says when it is building the RAID?


#12

Ugh…

I am trying to expand my 2TB ShareSpace to 4TB.  I put the two new 1TB drives in last night at 7:30pm.  Finished the raid 5 “recovery” around noon today.  Started transfering my data back.  A few hours ago, the unit froze up and my transfer canceled.  Couldn’t log on to the unit via http, couldn’t access anything.  All lights on the front of the unit were solid green.  Tried to shut the unit down from the front panel for about two hours.  Unit appeared completely locked.  Was forced to unplug to reset.

Upon reset, the unit is still inaccessible and I get a basic screen when I access from http.  No login, but a page that currently says “Building RAID 5 system… (6%, Estimated Time: 954.2min)”  There is a status bar that says 45%.  No idea what I am in for.

I will be setting up a support case to see what they say.  :frowning:


#13

I too assume that this would be a function to expanding. I have 2TB Model w/2 TB drives and 2 empty bays. I purchased two 2TB drives, thinking that if install into the empty bays, it would take me up to 6TB. Here is what I found out. The new drives must be WD…oops…! I purchased Hitachi 2TB with same spec. Very fast, error popped up stating that I must use WD only. What’s with this? I said to myself… Okay…WD buy WD! So now, I have the same question, if I buy 2 WD 2TB will it expand my box to 6TB (JTOB)?


#14

I just finished adding 2 new 1TB drives to my original 2TB Sharespace. It took it nearly 28 hours to format (recover) to a RAID 5 array. Once done it seems to be working well and with no difference in speed from the RAID 1 array that the 2 drives were set for. I added WD Black drives and the original drives were the Green drives but no ill affects so far.


#15

Well, its been a week or so and all seems to running smooth after the initial double format which took about the same 28 hours you referenced.  I used the identical green drives that came with the box.

I am still not sure about the answer I got back from WD where they told me you can not add drives larger than 1TB to the 2TB model.  Maybe if you want to use RAID 5 all of the drives must be alike, but the latest firmware update for the unit specifically says that it added drive support for drives larger than 1.5TB.

Anyway, everything appears to be working properly.  It is a shame that we have to stumble through these bumps alone with no true support from WD.

Good luck!


#16

That should teach me to open my mouth… sitting working tihs evening and all of a sudden the shares are unavailable.  Can’t get into the web interface, either.  Tried shutting down by pressing the power button for four seconds.  Got an email alert that the system was going to shut down, but it never did.  It’s been an hour.

Last time this happened, I ended up unplugging power and upon reboot the unit automatially rebuilt istelf and it wiped all of the data!

I am very concerned.  Any ideas???


#17

Forgot to update…

For anyone interested, the unit did freeze and I had to physically unplug the power again.  All booted up fine with no further issues.


#18

I tried to do that - and it DOES NOT WORKING!

Have a 2TB model with 2 x 1TB Green drives. Wanted to add 2 x 2 TB as a second RAID1. Thought I got 3TB at the end but had to realize the Sharespace can only handle ONE drivesize (for any RAID).

So I got a second RAID1 array with only ONE add. TB…

There is no comment for this at the menu.

So my over all experiance with that product is VERY POOR! Seems WD has good harddrives - but to develope a NAS it is more challenge…