Query on usernames, WD Sync error needing internet & safe streaming

Hi!
I’m brand-new to any form of NAS and I’m just getting it sorted. Yesterday I went through set-up and created the admin account and then three more for my OH and kids. I noticed though I didn’t seem to have an account in the same way under the name admin, so I created an extra one for me with my name. Was that the correct thing to do? I then realised that I had two accounts under the one email address, so I changed the one with my name to an alternative email address, as I didn’t want there to be conflict issues. Was that also correct?

My second query is about the startup software. I just went through the setup online at the mycloud.com/setup. However, when I had some issues later and was doing a lot of googling through help topics I discovered a page with setup software to download (http://setup.wd2go.com/?mod=product&device=mc). This didn’t come up during my online setup, so I’m unsure if I should use this too, or if this is made obsolete by the online one. I thought I’d try it due to my issues, but it couldn’t find my device (I think because I had changed the MyCloud name to a family one and couldn’t recall the precise original name). Should I use this software, and if so what should I change the device name back to?

My third query is about the WD Sync software. This is what the issues sprung from that left me spending hours googling and watching videos. I can use Windows Explorer from my laptop to drag things across to the NAS drive, and then download them to my kid’s laptop from My Cloud - so the network thing seems to be working. I have tried mapping folders/shares and that worked too. However, I didn’t realise that any of this was working at first because I thought it had to be done via WD Sync. I had downloaded this and installed it. It seemed to be okay - I asked for it to sync all the common ones (documents, music folder etc.) A new share did appear on the NAS - called WDSync - with various folders like ‘my documents’ inside it. However nothing has ever appeared in any of these folders! If I right click on the WD symbol in the tool bar, it says ‘no internet connection detected’ - but there are no other error messages. My questions are therefore, why is not syncing when the connection seems to be working elsewhere - and why does it want an internet connection for the LAN? (And there is internet anyway). I’m also confused as to why the new share is its own folder and not inside a user name - will this cause naming conflicts if I get it working and then install it on one of my kids’ computers? And do I have to use WD software to do this? I normally use goodsync with a hdd, and so if I could continue to use that it would be great.

A quick final query. I’d like to have things that stream to my smart TV (videos, photos, music etc) - but set so that my kids (or OH!) can’t accidentally delete them. I have tried playing with the settings after dragging some items into the public folders (which worked and streamed to my TV perfectly) - it seems to be okay if I set it to not public but to be media serving. However this seems counter-intuitive to set a public folder to be not public, and I wondered if the TV had just held the info in memory when I was testing. Are these settings correct or, if not, how can I have things available for my TV (or anything else here) to view - but not accessible to other users to delete or edit?

I do apologise for this super-long first post. I really appreciate any answers or thoughts at all. Thanks all.

Hi,

Yes, one account per E-mail is the way to go.

You can download the apps from WD’s site.

Please note that you can create private shares and allow permissions to specific users.

If you need additional assistance, you can create a case with WD