Puter not reading Drive

Can someone please help…I can’t seem to find anything regarding this issue I’m having. I have a external MY PASSPORT drive 1TB…It’s been my backup on my desktop. No issues till today. I start up my puter and reads other two drives as usual except thiis one. USB cable is plugged in and white LED light flickers then stays on…I changed cable and plugged it into my laptop and it doesn’t show up although LED light comes on…any help appreciated…


1 Like


Try some basic troubleshooting:

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the PC, not through a hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there.

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

ok…thanks but that didn’t work! BUT I solved it so pay attention campers with the same issue…

The drive I had an issue is the My Passport portable external 1TB drive. I purchased it about 2 years ago and used maybe 6 times total. I had it as a backup to an identical one.

The other morning my desktop (Dell XPS Studio/ Win 7/ i7/ 12 GB Ram) would not read the drive. I tried everything in I read here including the message above this one.

Here;s what solved it. I went to the WD site and downloaded the drivers and intalled the newer drivers. The file was actually WDFirmwareUpdater. I followed the instructions closely. HERE IS THE KEY…after numerous times following the instructions the puter would seem like it froze and take forever. I have little patience especially since this desktop is wicked fast. I kept unplugging and shutting down not realizing that it was taking it’s time doing it’s thing. On the last go round I figured I’d let it sit and do it’s thing. It took nearly 30 minutes for the puter to shut down. The whole time I thought it was froze cause I saw no movement. When I finally restarted it again it took forever to restart. I think it was like 20 minutes to boot up…then when it finally booted it was very slow BUT I saw the drive icon on my windows folder! Finally! I disconnected the drive and plugged it back it and it recognized it! I **bleep** down and restarted a few times and I’m back up and runnin! I hope this helps someone, I know how frustrating it is to loose a drive. I’ve lost several with important data over the years and I’ve sent them out for recover with no luck! Best wishes!!