Public folder not public and can't change it back!


So just today I received my brand new WD My Cloud 3TB. I tried setting some things when suddenly I somehow screwed the Public folder. It is not public anymore and can’t be changed to public either. So I gave everyone full access but still, I want to change this back to public.
So how can I change it back to public? Thanks in advice.

Sidenote - I also tried deleting and renaming it, but it said the following:

  • Deleting the Public share is forbidden. (400127)

Here’s a screenshot of the public folder not being public and unable to change to public:

The WD My Cloud user interface (Dashboard) generally keeps the “Public” share folder “Public Access” option locked so one cannot change the setting. However, due to a bug in the Dashboard it is possible to change the “Public Access” setting for the “Public” share folder. Simply try to change the “Public” share folder’s “Share Name”. Change the name and select the “Save” button. When you attempt to do so it will generate a error message indicating the Share Name cannot be changed. After dismissing the error message (by clicking the OK button) the “Public Access” option becomes active and can be set to either On or Off. 

Thank you so much, it worked! :slight_smile:

I have found this thread and I think it would be the solution of my problems but it looks that the bug persists in the new version of the dashboard but I cannot change the name of the folder to do the trick.

shakeador, with the OS3 firmware released last September WD “fixed” the bug in the Dashboard that allowed one to change the public access setting on the Public folder. Here is one such post mentioning that the bug was “fixed”.

There are some potential ways to get around WD’s insistence of not being able to set the Public folder to private but it may involve some work to do so. There are several earlier threads, like the following, that discuss attempts to set the Public folder to private.

Thank you, I’ve found out that the easiest way was to solve my problem was to factory restore system only; my shares remained the same and I only had to create users and set permissions.