PS3 can't see files in a created Share outside Public

I recently got a WD My Cloud. I tested it by putting a few video files into the “Public\Shared Videos” folder. On my PS3, I could go into the “Videos” tab, select my WD Cloud, and I could see the video files I’d placed in the “Shared Videos” location. It was the same thing with music files I’d put into “Public\Shared Music”.

I then created a Share called “Movies” and a Share called “Music” on my WD Cloud. I moved files into each of them, but none of those files I put into those Shares show up on my PS3. On the PS3, in the Video or Music tab, it sees my WD Cloud as a source, but when I choose it, it says “There are no titles.”

Here’s what I have tried. Yes, my PS3 is on the same network.

  • Firmware is up to date
  • Rebooted after media was moved into the new Shares
  • Using browser-based interface, made sure both Shares were set to “Media Serving” is On.
  • In Settings/General, Remote Access is On (not sure if that matters)
  • In Settings/Media, DLNA Media Streaming is On.
  • The PS3 IP address is seen in “View Media Players”
  • I have rescanned DLNA database. I hope I don’t have to rebuild, it takes forever, jah?

PS3 could see media in Share named “Public\Shared Videos.”
PS3 cannot see media inShare named “Movies” or “Music” even though I think settings are same.

Thank you for any solution to this problem.

1 Like

Thanks cpt_paranoia, I will give that a read later tonight and let you know if it works out. Appreciate it!

I found a solution (near the end of my post). I have no idea why it works, or what the problem was with my previous settings, but it is what it is.

Thanks cpt_paranoia for pointing me towards your guide, specifically the Twonky settings. You are doing a great service helping out by writing and compiling all the info, so thank you!

  • I checked and rechecked all the Twonky settings, and had no success. I made sure the Shares folders I created where all my media was stored were selected to be shared in Sharing | Shared Folders. They were, but Twonky didn’t care.

  • Having no success with Twonky settings, I moved everything from my self-created Shares back into Public ---- and none of the files were visible. The WD manager showed thousands of video and audio files, but Twonky showed zero being shared. Twonky didn’t care.

  • I went back into Twonky, and specifically into Sharing | Shared Folders … I confirmed that Public Share was selected, and it was, but Twonky didn’t care.

  • Getting curious, I decided to change the folder that was being shared. Specifically, I went inside the Public directory, and selected the Shared Music and Shared Videos folders.

And wouldn’t you know it, Twonky cared! Twonky started rescanning my folders, and found all my media.**

Thanks cpt_paranoia for pointing me in the right direction.

But to WD, it is unbelievable that I needed to go into those settings and specify subdirectories of the “Public” share. I wonder how many people have simply returned your drives for similar reasons, because the average user certainly isn’t going to bother to (or can’t) take the time to figure out how to make the thing work properly.

Thread resurrected by your ‘like’…

I’m not sure why you couldn’t get Twonky to scan your private share; it works fine for me.

There are two possibilities I can think of:

  1. You didn’t enable media serving on the share (Dashboard)
  2. You didn’t hit ‘save changes’ (Twonky).

Sorry the FAQ didn’t help you directly.