Provide Feedback Here


#1

Please use this Forum to provide feedback, issues, bug reports. Please make sure to include the following in your reports:

  1. Your Name / Forum or Real
  2. Serial Number of My Passport Wireless Pro (so we know which LOGS are yours)
  3. Description of issue
  4. Detailed steps to reproduce the issue
  5. Observations, Notes, Comments
  6. LOGS of the issue immediately after the error – NOTE: do not power cycle the MPWP or the logs will be lost

To get the LOGS mentioned in #6 above, do the following:

  1. Connect your PC (Windows or Mac) to the SSID of your My Passport Wireless Pro
  2. Open a web browser and enter the following address into the URL field of the web browser:
    On Windows: http://MyPassport/ or http://192.168.60.1
    On Mac: http://MyPassport.local/ or http://192.168.60.1
  3. Navigate to the Support Tab of the Dashboard
  4. Under the “system Reports” heading, click the “DOWNLOAD” button
  5. The report will be saved to your PC
  6. Upload the log to your own Online Drive location then provide us the link – if you have any issues uploading the logs, please Private Message me the logs.

Welcome to the My Passport Wireless Pro FW BETA
Provide Feedback - Win a Prize
#2

Provide Feedback - Win a Prize
#3

#4

Who's Participating
1.02.21 Firmware Release – 17NOV16
1.02.20 Firmware Release -- 07NOV16
1.02.20 Firmware Release -- 07NOV16
1.02.20 Firmware Release -- 07NOV16
#5

I connected my Hero Session 5 via USB cable to the MyPassport running 1.02.20, Session is running v01.50.

  • MyPassport was running.
  • Plugged in the session 5 (with the USB C cable in the box from GoPro).
  • Powered on the session 5
  • Session shows it is charging and the USB icon (same as I see when transferring files to my MAC or iPhone w/camera connection kit).
  • Opened the WD app on my iPhone and selected to transfer the files from the USB drive.
  • I saw an error message that said ‘USB Device Not detected’.

Attaching logs.
https://www.dropbox.com/sh/vhp6u0xppa9f2js/AABITAgI_qb1oHv0Kc0Sbt55a?dl=0

Note: After I powered everything down and back up again it worked… pulled the logs after things were working.
UPDATE: I was tricked… it said it was working, I saw "all’ the lights blinking and based on the dialog box (don’t remove till battery lights stop blinking) I thought things were working. 45 min later when nothing showed, I contacted James who informed me that all lights blinking is an error! :frowning:

FEATURE REQUEST: Dialog should tell user that ALL lights flashing is bad!!

SN: WXL1EB5CUF74


#6

@bens9512

Thank you for the report, we will investigate and attempt to reproduce. If you are able to reproduce this error, please download the logs right after the error occurs, before you reboot the MPWP, then provide those logs again.

@jrichard


#7

logs were pulled when I thought it was working, hence, while the issue was occurring the 2nd time when the system faked me out.


#8

Thank you for the follow up, I have created a BUG on this issue, and entered you into the drawing for a prize


#9

I have yet to see the ‘auto’ import work. I have placed 3 different SD cards into the WDWP as well as plugging in my session 5 and I have to kick the import process each time even though I have the ‘auto import’ toggled to ‘on’.


#10

Received notification that I could join the Beta. Tried 3 times to manually install the beta per the instructions over wireless but no success. Tried the Quick Test which came back clean. This is the error

Invalid firmware package. (370001)

Updating from My Passport Wireless Pro v1.01.11

Downloaded firmware:

MyPassportWirelessGen2_1.02.20.bin

From the update.log

updateFirmwareFromFile.sh:11/14/16 19:55:53:upgrade start: /CacheVolume/MyPassportWirelessGen2_1.02.20.bin
updateFirmwareFromFile.sh:11/14/16 19:55:53:check_size=
Error fw_update_status: failed 200 “invalid firmware package”
updateFirmwareFromFile.sh:11/14/16 19:55:57:failed 200 “invalid firmware package”

Formatted an SD card to FAT32, created the update folder and copied the bin file to the folder. Rebooted the Wireless Pro with the SD card installed and the update worked.

Link to report after last wireless failure

https://drive.google.com/file/d/0B_bRcT0-zMUOWkdjaUJvcU8tb28/view?usp=sharing


#11

@nbourbaki

Thank you for the report and the logs, we have filed a bug report (and entered you into the drawing for a prize) we will look into this right away.

@jrichard


#12

@nbourbaki

After analyzing the logs, it look to be an HTTP request time out during the connection, this resulted in an incomplete upload of the FW to the MPWP. Can you please tell me the following?

  1. What type of Network Connection did you have - Direct to MPWP or through home Router?
    – Direct = PC connected to SSID of MPWP
    – Router = PC connected to Home Router and MPWP connected to Home Router
  2. What OS & Browser (plus browser version) are you using?
  3. Are you connected to MPWP via 2.4 or 5 GHz

@jrichard


#13

Jr,
Yes, I thought that might be a problem, so I direct connected on the
5ghz SSID channel of the MPWP on my last wireless try, that is the log
I sent you.
MacOS, Sierra v10.12.1, Safari v10…1
5ghz
I do have the ethernet network connection as the highest priority in my
network contfiguration and that’s directly connected to my TP-Link
1900ac router, but it’s a 1gb link and the MPWP is only 1 foot away
from the router, so even if it was taking the eithernet path, it would
exceed the network bandwidth of the MPWP easily.
Thanks
Charles


#14

@nbourbaki

Thank you for the quick response, I have updated the bug report with your valuable data.

@jrichard


#15

Name: BrianAz
Serial Number: WX51E857JUM7
Description of issue: I have a static IP assigned for my Passport on my home router. It was linked by mac address. After the unit came back online, it was given an IP from the general pool since it’s mac address was different.
Detailed steps to reproduce the issue : Assign unit a static IP on your router based on MAC address. Apply fw upgrade. MAC address changed and therefore was assigned an IP from the general DHCP pool rather than the static IP assigned to it.

Note: The unit is working fine after the fw upgrade. I am reporting the possible issue because it was not using the IP I expected it to. Initially I thought the fw upgrade may have failed. Took me a few moments to go and see which IP it had been given via DHCP.

LOGS of the issue immediately after the error :
Sent to @jrichard via PM.


#16

@BrianAz

Thank you for the detailed report and logs. I have created a bug report on this issue and will follow up with you once I get more information.

I have also entered your name in the drawing for a cool prize :slight_smile:

@jrichard


#17

AUTO-IMPORT:

Since my last message I have been using the auto-import feature and found that it does actually work… it just takes a while to let you know its working.

Im using a couple San-Disk 32GB cards which are ~75% full and I am seeing it take ~10seconds before there is any user feedback that something is happening. While 10 seconds isn’t a terribly LONG time, it is long enough that as a user I felt it wasn’t working and I went ahead and pressed the import button manually. Whats the point of the auto-import if you are not sure its started and the button is right on the front? I could see this being an issue for (as an example) photographers in the field… their memory card fills up, they pop it out of the camera and into the MPWP. For ~10 seconds they need to stand there and wait to see if the system sees the card to start the import while missing picture opportunities.

The system should (regardless of auto-import) give feedback that an SD-Card is seen OR a USB device is seen after attach. This gives me confidence since there isn’t a screen on the MPWP to show me my card/USB device mounted correctly.


#18

Name: Robbert
SN: WXV1E653SWN2
Unable to install beta firmware: MyPassportWirelessGen2_1.02.20.bin
Steps: Loged in the MyPassport UI through web interface with Safari. Selected the downloaded firmware and tried to install. All attempts fail with Code 1003 fail message.
Reboot of device did not change behavior. New download of firmware doesn’t change the issue.
Logs: unable to attach due to new user restrictions of this forum, but available.


#19

@roma

The Forum won’t allow you to upload files, you will need to put them on your own cloud share like Dropbox or Google drive, then you can send me a Private Message with the link.

Once I get the logs, we can investigate further.

Can you tell me what OS version as well as Safari version you are using?
Are you connected to the 2.4 GHz or 5 GHz band of the My Passport Wireless Pro?

@jrichard


#20

Link to logfiles:
https://www.dropbox.com/sh/yrzih2ja4k6796z/AAByW6XqPORm_PHnG9hSi486a?dl=0