Product registration not working

Hello, I could not find a registration forum.

The product registration interphase is not working, I have been trying to register my product for several consecutive days, without being able to do it.

I enter all information and at the end a message appears that reads. “We are sorry but this action can not be completed at this time. Refresh your browser and start again”. I have done this several times, please advise.


don’t bother hoping for help from WD

go read the other forum. they are scammers now.

Me too, I am not able to do for “My Book” registration today (24.07.2020)

So I have posted a complaint in another forum and now I am doing it in this one. I have not been able to register a drive I purchased, I have tried multiple times.

WD? I am hoping they will direct us or offer an explanation. It does not make any sense, they have made great products for years, this must be temporary.

Having the same issue myself, just bought a SN750 1TB drive. Get the same error: “We are sorry but this action can not be completed at this time. Refresh your browser and start again”

later edit: Tried again using a blank Edge (no addons). Worked for me.

Same issue here - Might I ask, can your all confirm whether or not you bought the heatsink-less version? Perhaps from Best Buy even?

I get the feeling these drives were supposed to have the sink installed by design, but then when WD realized nobody wanted to pay 25 bucks for a hunk of metal on their SSD and were all instead buying the bare drives… The halted adding sinks, but neglected to update their SN records.

Even if that’s not the case, whatever it is, they need to get their ■■■■ together lol

Mine has the heat sink actually. Using the board’s built in one on a different drive.

Try using Edge with no extensions, it seemed to have worked for me to do it.

I too encountered exact same error message several times today when trying to register a new product using the Firefox browser. Following other comments above, I decided to try registering using the Microsoft Edge browser. It worked first time.

WD really need to sort this out. Considering how many people worlwide use Firefox it’s shocking that your registration page is clearly not compatible with all popular web browsers.

Yes, I got the bare drives.

Thank you, that information helps.

WD cannot register its own Product. How come?

Are you asking how to register your WD Device (Product)?

I’m fairly sure Western Digital knows how to register their own products.

Warranty Status | WD Support

I have been trying to do this for months, frankly it is ridiculous. I still have not been able to register 2 drives.

cat0w do you work for WD?

No sorry. I also try to email them but it seems like no way in.

Is this where you are trying to register?
Product Registration | WD Support

What about Chat Live, does that work?

No,I do not work for WD. I own two WD MY CLOUDS. WDMyCloudImage

Try, Message, Bill_SWDStaff

It worked for me if I switched to a new browser
Firefox - not worked
Chrome - worked fine

Thank you.

Yeah it works in Chrome.
FFOX is my preferred browser.

Re: FFOX i think it’s a 3rd party cookie setting and maybe tracking protection. The FFOX web tools show alot of complaints on these

Did you look at the date for this topic and the dates for replies? Topic started July 2020. Last reply before yours, May 2021.