Problems with WD Caviar Black 750 HD


#1

Hope someone can help me here. I bought an OEM WD Caviar Black for my new system from NewEgg. Worked fine with a fresh install of Win 7 RC for about 2 months. Then, things started freezing (games, movies, etc). Got to the point where it would not boot into Windows. Had an old HD from another company. Formatted it, loaded Win 7 on it and everything been working fine.

After the install on the old HD, I went into BIOS and it showed the WD HD as it should. Turned off the PC, waited 10 mins, went into BIOS agian and this is what it showed the WD HD as : BzBzBzBzBzBz. I used the older HD for about 2 days trying to find some help on what was wrong on my new WD HD. I finally went back into the BIOS and it showed the WD HD listed with the right name. Rebooted using Win 7 CD, formatted the HD, reinstalled OS and it worked. It has worked now for about 4 weeks, and it began freezing in all programs and would not boot into Windows. Again went back to my old HD, went into BIOS, showed the WD HD named correctly. Tried to format using Win 7 CD and it said drive could not be formatted.

Very frustrated at this point, I went into Windows and used the format option there. It formatted the drive, but now it shows 2 drives. Drive E System Reserved with 99.9 Megs,and drive F as Local Disk with like 589 Megs.

Two questions arise from this.

1)Is my HD bad?

2)If its not bad, what do I do to fix it.

Thanks, and sorry for the long post.


#2

Assuming the drives haven’t been dropped, you might have a drive size limitation in your Bios.  Check for a bios update and see if that fixes it.