Problems with Time Machine since Mavericks upgrade

Time Machine backups were working well on the drive until Mavericks upgrade. Now terribly slow. I haev even tried deleting the file and starting from scratch with little improvement. Drive seems to work well otherwise and writing other files to it is fine. Any suggestions?

Mavericks is likely the problem. CHeck online the many problems it has from erasing RAID drives to slowing down backup performance to a crawl. It could be your drive as well, so check with another Mac not using Mavericks to check.

Yes since posting I have noted the discussions on the Apple forums. Mavericks does appear to have caused a problem with Time Machine that hopefully Apple will acknowledge and fix soon.

Incredibly this is still not sorted. Started a new back up this evening not having done one for 3 weeks. It is trying to back up 140 Gb but has taken around 6 hours for the first Gigabyte! It’s just not useable currently. I have tried a number of solutions from Apple forums without success.

Any updates on a resolve to this issue…ie Mavericks upgrade. WD /Time Machine not functioning ?


Im now using a lacie drive with time machine and mavericks with no problem. I have had my WD drive repaired but while it works for the IT guy it wont work for me!