Problems with older My Book 1 Terabyte Hard Drive

I have an older My Book external Hard Drive with both fire wire and USB 2.0 connectors. Today (10/28/16) when I tried to access the drive I notice a flashing light when power was applied. Normally I have a solid light on the front of the unit until the unit connects to the computer that it looks more like what you would have seen on the front of the night rider car Kit the light goes back and forth. At one point the light went out and when I checked my computer to see if the drive had connected the drive was not found. I am trying to figure out what is going wrong or if some has had this problem and knows how to solve it.

Thank you for any assistance that anyone can provide.

Roy Saxman


I recommend you try replacing the USB cable and/or power adapter. Also, if possible try it on another computer.

Hamlet, First I want to thank you for the information that you provided. I tried everything but the USB cable change worked once and then not again. So I thought about it and then decided to take the case apart and try plugging the hard drive directly into a SATA external dock. When I did that the hard drive was totally accessible. So I am going to have get a SATA external case to put the drive in so that I can use it continually with a laptop for storage and working with FLV and mp3 files. Again thank you for the information.