Problems with .mp4

Hi all,

I’m having problems playing 720p movies (around 2gb) in the mp4 format: they don’t play smoothly, in several moments they kinda “jump” from frame to frame, like if they block for a second and then jump to the next frame. On the other hand I don’t have any problems playing 720p movies in mkv, they’ve always worked fine.

Any idea about why this happens and how to solve this? (besides avoiding mp4 and only get mkv…!!)

Thanks a lot

Can you post the media info of those files and the info on the Elements Play you have (There are two versions)?

I have a WD Elements Play multimedia drive 1 TB. I have a macbook pro OS X 10.7.2 (Lion).

I see my WD has problems with all the mp4 (so I now avoid them) but never had any problems with mkv. I tried converting the mp4 to mkv but the problem got worse.

about the details of the mp4 files here’s one:

*Type/Codec/Writing Library: MPEG-4 AVC/H264/x264
*Container…: MP4
*File Size…: 2.18 GB
*Duration…: 1h 56mn 38sec
*Bit Rate…: 2292 Kbps
*Bits/(Pixel*Frame)…: 0.141
*Resolution…: 1280x528 pixels
*Aspect Ratio/Frame Rate…: 2.40:1/23.976 fps
*Stream Video Size…: 1.87 GB (86%)
*Stream Audio Size…: 320 MB (14%)
*Audio/Bit Rate…: AAC LC/384 Kbps
*Channel(s)/Sampling Rate…: 6 channels/48.0 KHz
*Channel Positions…: Front: L C R, Side: L R, LFE
*Sample Video Runtime…: 41sec
*Source/File Size…: Bluray 1080p-AToM = 8.91 GB

and another one’s:

Format : MPEG-4 at 888 Kbps
Length : 1.17 GiB for 3hrs 8min 39s 

Video : AVC at 757 Kbps
Aspect : 1280 x 528 at 23.976 fps

Audio : AAC at 128 Kbps
Infos : 2 channels, 48.0 KHz


i’m noticing the same issue as well, any updates would be appriciated

I have same issue with my WDBACC0020HBK. All MP4 content 720p/1080p that I try to play has issue with “smoothness”. After few mins of watching, it becomes unbearable.

Considering last firmware update was late 2010, and other WD products are receiving new updates for the past few months, can we at least get ETA on WD Elements Play new firmware?


On the subject of current firmare versions.

I have recently purchased 2 elements play 1tb players.

One has 1.00.85 version the other 1.01.12 version.

On western digitals download site the current version is 1.01.10

Now correct me if im wrong but that appears to be a lower version than 1 of my players.

Contacted WD about this…still awaiting reply.

Also my account states 1 player has 600+ days warrenty, the other 200+ days (whats that all about) lol

Hey, not sure if you ever fixed this problem, but figured I’d post here to hopefully help a few other people.

It’s true that mp4’s just don’t seem to behave well with these harddrives, every single HD mp4 i’ve ever tried has had some slight skipping, the video completely freezes a few mins in and you can’t seem to fast forward without the file restarting from the beginning.

If you have all these issues, the way I get around it is converting the mp4 to mkv, then remuxing the mkv file (if needed) with the files below. (This process only takes a few mins at most, sometimes seconds depending on file size).

Firstly, check out post 4 of this thread:

You’ll wanna grab the 2 files that were linked (MKVFix and MKVToolNix v4.3.0).

Step 1.

Once you install both, go to where you installed MKVtoolnix.

-Run mmg.exe

-Click ‘Add’, then find the mp4 file that is giving you issues. After it’s added, you’ll see under Output filename it should rename it to an .mkv file. Click ‘Browse’ to choose where you wanna save it.

-Click ‘Start Muxing’

Step 2.

After that is done, run the program MKVFix.exe.

-First thing you wanna do is click ‘FindMKVToolNix’, then locate mkvinfo.exe wherever you installed MKVtoolnix.

-Then click ‘Run Search’ and point it to the folder where the .mkv file that you converted from Step 1 is.

  • If it isn’t highlighted RED, it should work fine as is. If it is highlighted RED, select ‘Header Compression Only’ down the bottom and then click ‘Clean Files’

If you have alot of files to convert, it’s best to put them all in the same folder, so you can fix every file at once instead of doing it one by one.

After that is done, you’re newly converted mp4>mkv file should play perfectly now!

It’s a little more work but I don’t see WD ever fixing this considering there hasn’t been a firmware update for like over 2 years or so. TV shows etc are moving towards x264 codex with mp4 container now, so this fix works great for that too.

Hope this helps someone XD

There’s no need for a two step process: you can all do it in “MKV merge”:


On the “input” tab, for each track, under “extra options”: make sure compression is set to “none” for all track types (video, audio, subtitles) where the option is enabled (e.g., not for chapters).

Just my 2 cents …