Problems with MBL and Time Machine

Hi all,

as subject, I have a big problem with Time Machine and my new MBL: I can’t succefully perform the backup, the process hangs continuosly. I have to backup 55 Gb but approx at 10-20 Gb the process hangs and I can’t proceed.

I tried several times, I performed a quick reset but it doesn’t solve. Now I’m trying with an hard reset (and it is taking a lot of hours).

I am very disappointed, I bought the MBL basically to perform the backup with the Time Machine and I chose the MBL for the compatibility with that.

Could you help me?

The hard reset doesn’t solve the problem!

For an additional information: in the control panel screen (via Bonjour), in Backup screen, I get this error (the same before and after the hard reset):

Fatal error : Cannot use string offset as an array in /var/www/UI/app/views/themed/default/backups/index.ctp on line  19

Please help me!

I have the same problem. I also bought the disk to use it with TimeMachine, and it is useless. Today I am trying to do backup with a direct ethernet connection with my iMac (after thinking the problem had to do the router), but right after mounting the backup disk, it dismount it with the message: “There is no available disk to do the backup of”.

I tried the normal soft reset, but it is the same.

Captura de pantalla 2011-03-06 a las 11.30.58.png

I am very frustrated about this problem. I bought MBL for this compatibility and I paid for it!

Now I am trying to continue with the backup… Sometimes when backup hangs down, the next restarts from the point where the previous stopped (but not always). I hope to go on end.

In any case I have big doubt about the restore of files in the future… Will it work???

I think that I will ask for a warranty replacement if nobody (of WD) will help me to solve this problem.

I have had “only” the problem " Fatal error : Cannot use string offset as…" in backups. First, I found this link:

http://wdc.custhelp.com/app/answers/detail/a_id/5732/~/error%3A-%22fatal-error%3A-cannot-use-string…%22-is-display-in-the-my-book-live 

but in my case no quotation marks were present. I checked the hostname (the Mac Book computer name) and I found some extra spaces at the end of the name ("MacBook of Firstname Lastname "). I have enabled the SSH connection to NAS and found the directory: /DataVolume/backup/TimeMachine. Inside this directory there was a directory named:

“MacBook of Firstname Lastname .sparsebundle” note the extra space before .sparsebundle.

I deleted the whole TimeMachine directory (with Mac Book offline) and renamed my Mac something like “MacBookNS” (no spaces, no dots, no quotation marks, etc.). Enabled the Time Machine backup and problem solved!!!

So, in my opinion, the problem is due to a bug in the web interface of the NAS (I have the last firmware 01.04.06).

Hope this help.

Do you mind telling me how you enabled SSH? I have a mac and a pc, so I could try this out. I’m getting this error message as well and I’d really like to just delete the old back ups and start from scratch. 

Easy. First login as usual to the web interface, then manually change the address from IPOFMYBOOK/UI to IPOFMYBOOK/UI/SSH. A secret page will appear: check Enable SSH Access. Now you can use a terminal window in your Mac and write:  ssh root@IPOFMYBOOK. The defaul password is “welc0me”. Good luck.