Problems with Amazon S3 Jobs

I purchased a new WD MyCloud EX2 because along with other features, WD claims to support Amazon S3 backup.  Also, I am running firmware 1.03.41.


I am very familiar with Amazon S3 because I also own a Qnap NAS that I’ve used for three years and utilize the S3 support inside the Qnap.


On MyCloud, I have created multiple S3 backup jobs and know they are configured correctly, why, it’s virtually impossible with your interface to configure an S3 job incorrectly.  Some of the S3 jobs (queues as you call them) are configured to run on a daily schedule, some I run manually.  I have all my S3 jobs setup as Type: Upload and Backup Type: Overwrite Existing File(s).  I DO NOT want to use the other Backup Types (or modes).


Over a week ago, I setup four S3 queues to run each night at different times.  I wanted to ensure your S3 jobs were running correctly, so I logged into MyCloud and looked at the details/status for each S3 job.  I saw Finished on some jobs and Ready on others.  This was the first indication that something might be wrong.  I then looked at the details of the job, clicking on the Progress “List” link.  From the start date/time, anyone would assume the job ran correctly, but I was not convinced.  So using an S3 browser, I checked my Amazon S3 buckets to determine if your S3 queues were operating correctly. They were not because I found missing files/folders in my Amazon S3 bucket that were present on MyCloud.


I then went back to MyCloud and clicked the right arrow (triangle) on a particular job to run the job manually.  The dialog box “Are you sure you want to perform a backup now?” popped up and I clicked OK.  Then the “Updating” message popped up for a few seconds, but the job does not start.  I did this over and over, so then I decided to reboot MyCloud.  After rebooting, now I could manually start an S3 job and I verified the missing files/folders were properly copied to my S3 bucket.


The problem is if several days go by this same problematic condition returns.  I have to reboot MyCloud for S3 jobs to properly execute.


I have deleted the jobs and recreated them, etc. etc. but I should not have to do that.  You have problems with your implementation of Amazon S3 backup jobs in your job scheduler or some other area.  If the MyCloud runs for several days, it can cause the S3 jobs to not execute per their schedule.


Is WD aware of an issue? If so, what is WD doing about it?

Before I went to bed last night, I rebooted MyCloud EX2.  When I checked the status of the four Amazon S3 backup jobs scheduled to run during the night, this morning three list their status as “Finish” one lists “Ready” as its status.  Why one has a status of “Ready” and not “Finished” I have no idea.  If the three jobs that say “Finished” really ran I also have no idea, yes I can click on the details option and I see a start time/date, but I can’t be sure they actually ran.


The one S3 job that has a status of “Ready”, also lists a date/time under its Details option giving the impression it ran, but I know 100% it did not run because I created a small “test file” in the folder to be backed up and that “test file” is not in my Amazon S3 bucket.  All four S3 jobs are scheduled to run at different times and based on my internet connection upload speed and the number/size of files to be backed up, I am 100% confident the backup jobs will overlap if they run at the times I configured.  I organized the jobs this way because I did not want to overload the MyCloud with simultaneous S3 jobs … remember, I have a lot of experience with creating well organized and properly scheduled S3 backup jobs on a NAS (years of managing numerous other NAS systems from different vendors that all support Amazon S3).


For the job with a “Ready” status, if I press the right arrow (triangle) to manually run the job I get the pop-up dialog message asking me if I want to backup now, I then click OK but the job DOES NOT start.  Getting frustrated, next I rebooted MyCloud and now when I manually start the backup job and select OK in the confirmation message, the job starts.


What attracted me to the MyCloud EX2 is the brilliantly clean, simple, and extremely easy-to-use web interface.  As I said before, I’ve used/managed several other NAS and with more robust feature sets, but I have to say that the MyCloud EX2 seems to be a great home NAS and even a very capable NAS for many businesses scenarios, but regarding the Amazon S3 backup option, there is defiantly something wrong with the scheduler or some other component.  It’s almost like the MyCloud is getting “overloaded” and “jammed up” when running S3 jobs.  In any case, I’ve seen something similar when I watched/helped Qnap debug their Amazon S3 feature over a two year period.


So again I ask … is anyone else seeing any problems with their Amazon S3 backup jobs?  Is WD aware of any issues related to Amazon S3 jobs that are configured to automatically run at different times?



It seems strange that in over a week no one from WD, or anyone else in the community, has posted a comment and/or suggestion.  I don’t know from the silence if this means no one else is experiencing any issues with Amazon S3 or what to take from the silence.

The main takeaway from the silence is probably no one who’s a forum contributor has any experience with the S3…not that no one is experiencing any issues. It seems strange to me to assume that there’d be any S3 users here. If it was something more common - say Dropbox or Google Drive, etc. users, yes, chances are higher to find an user like that here. But S3 isn’t as common as you might be thinking it is.

I’ll just chime in that I’m seeing similar problems using the S3 queued jobs. Looking for answers as I’d like to have the EX4 backup certain folders to S3.

I am using an ex4 with 1.04.04 firmware.

I have one job that has completed according to the ex4 and several that show failed. I have not validated the successful backup yet, and until I see some success from the jobs/queues I’m going to consider this capability is not functional.

Cross-referencing a similar issue with Amazon S3 backup feature with the Mirror ->

I’m still not making any headway on this … my support ticket is still open, but noone on the other end of it appears to be very responsive.

Should we conclude that the Amazon S3 cloud backup feature (one of the main reasons I purchased this device) is basically unfinished and practically useless?

Yes, quite possibly, I’m afraid. There was an FTP bug that I had reported within a week after product launch that rendered FTP practically useless for 5 months until they finally fixed it in the latest firmware release, but without even notifying in the release notes that it was fixed ( ).

So your Amazon S3 backup feature may someday get fixed…or may never at all, given how few people use it. Not saying that’s a valid reason for an advertised feature to not to work, just saying like FTP, few people really use it (I’d think even far fewer than those who use FTP actually) so they can continue to ignore requests for a fix for as long as they like, unfortunately. For me really the main reason I had bought my EX2 was to use it as an FTP server, and was sorely disappointed but WD did reach out to me and made a generous gesture…so I came off feeling that they aren’t totally unresponsive to consumer complaints, but it seems their engineering teams were/are not adequately resourced and simple bug fixes can take a good deal of time.

That’s a shame.

I wonder if there would be any interest at WD in open sourcing their S3 client (it’s very likely that it has a open source base, even if they’ve customized it somewhat for the device). Or failing that finding some alternative client that can run on it … has anyone had any experience in that direction?

I returned my first EX2 about a month ago because in addition to my bad S3 experience, I was also having a problem with overheating and saw the fan speed was always reported as zero RPM.  I think the problem is/was related to software/firmware controlling the fan, but I was never able to prove that theory.  Anyway, I love the great value of the EX2 so I purchased another unit and have been running it this week.

The problem I was having with my S3 backup jobs related to more of a condition that arose over time.  I created four separate S3 jobs. Starting from a fresh reboot, if I started each job manually each job seemed to run correctly.  But if I setup a schedule to run the jobs, let’s say each night, I would notice “strange behavior” that built up over several days (e.g., jobs would not always run, or they would run but not all files would backup).

I realize that with all the other applications running inside the EX2, these kinds of issues, especially issues that seem to “build over time”, can be extremely difficult to resolve.  As I said in my original post, I also own a Qnap NAS and for many months I worked directly with Qnap’s Taiwan software team to help them eventually resolve their own S3 problems.

With my new EX2 I have not yet configured my S3 jobs, but I will shortly and try to gather more information to share here.

@MrqDude out of interest, how big were the individual jobs? How long did the early successful ones take to complete?

Of the four jobs, one was small (under an hour at 5Mb/sec upload), one included roughly 2800 files totaling about 4GB, one was about 900 files totaling 6GB, and and one was about 12,300 files files totaling 16.5 GB.

All backup jobs were sent to incremental, so the first run took the longest, but subsquent updates, which ran each night, usually finished each job in 10 to 15 minutes.