Problems transferring files from MyBook to MyCloud

Hello everyone,

I just bought a MyCloud 4TB. I had all my info in a MyBook 4TB so now I have to transfer everything from the MyBook to MyCloud.

I’ve been trying to accomplish this task since about one week with no success.

After I begin to transfer folders from the MyBook to MyCloud the transfer stop. It always happens after maybe one or two hours since the transfers start.

I have a total of 3TB to transfer, and this has been a constant pain, it’s been almost a week and I’ve only managed to transfer about 1TB.

File transfers keep stopping.

I have the MyBook connected directly to MyCloud through the USB 3.0 connection, the MyCloud is connected to the router and the computer is a Mac connected Wi-Fi.

I can’t believe this is normal, the files just have to move from the MyBook to MyCloud through the USB 3.0. That should be extremely simple.

After the transfers stop I keep getting different error messages, “you don’t have permission…”, "“the server is not responding…” etc. The transfers start perfectly, then I leave the computer running. After one or two hours when I return to check, the transfers have stopped and I get an error message.

I have the latest firmware on the MyCloud, I have reseted everything, the MyCloud has a static IP address, it just doesn’t make sense.

Why do I have to keep wasting so much time in something so simple?? This product should be able to do these tasks without me having to be a computer engineer or without having to tweak and change all imaginable settings in the router, computer, network, etc.

Any advise will be greatly appreciated.

Thanks.

1 Like

Hello,

MyCloud Service, iTunes and Twonky DLNA are enabled by default.
The very moment data writes to disk, the Cloud Service starts generating thumbnails and Twonky starts indexing which increases the CPU and Memory being used. There could also be some SMB issues as well.

TRY THIS:

  1. Disable Cloud Service for now
  2. Disable DLNA
  3. Disable iTunes Server
  4. Reboot

Use this KBA to transfer directly from USB to MyCloud instead of your PC (Samba)
NOTE: Single Bay My Cloud does not support the installation of Plex, but it works for all types of data.

Thanks SBrown, I will try it right away and let you know of the outcome.

Thanks Again!!

Select the Apps tab of the navigation bar

Select Web File Viewer and wait for the Shares to appear

Those are going to be difficult on a basic MyCloud, since it doesn’t support Apps…

The MyBook is a USB HDD. Even WD recommend that for bulk data transfers from a USB HDD to the MyCloud, the best way is to connect the HDD to a PC, and use the PC to transfer files to the MyCloud.

In order to do this, you will want to map the MyCloud as a network drive (by far the best means of accessing the MyCloud on local network from a PC):

Hello SBrown,

I am trying to disable Cloud Service, but when I sing in at my cloud.com I get the error Can’t Connect To My Cloud and it says that the device is offline.

Almost every day when I try to sign in to mycloud.com I get the same message, but the device is turned on, with the blue light steady, and connected to the network and internet, and I even can access the MyCloud’s folders and files.

In these last 7 days I’ve seen the same message like 5 times, and I have to restart everything: computer, router, and MyCloud to solve it, but after a while, the same problem repeats.

Again, I can’t comprehend that the solution is for me to turn off and reset all the devices everyday for MyCloud to be working as it should be.

The device is new, the setup is basic, and I’ve only tried to move files from a MyBook to a MyCloud.

What can I do to correct this issue?

Thanks!!

To disable Cloud Access you will need to access the My Cloud Dashboard (http://wdmycloud or http://wdmycloud.local) NOT MyCloud.com. Generally you can only access the Dashboard while connected to the same local network as the My cloud. The MyCloud.com web portal is generally for accessing the files on the My Cloud, not administering the My Cloud features (other than adding a new user).

Hello Bennor,

The MyCloud stopped responding. It’s like it’s not there.

First I reseted the computer, the router, and the MyCloud.

Then I tried to access the settings through http://wdmycloud.local with no success. I was able to login, but then I couldn’t do anything else.

The interface is responding extremely slow, the page took like 5 minutes to load. I clicked on settings and after waiting for 5 minutes nothing happened and the page went blank. Then after 10 minutes the settings page started to load, but very slowly. After a while the page went blank again.

I tried again to access mycloud.com and it says again that the device is offline.

I went to Network and clicked on the MyCloud icon and after a while it said Connection Failed. I can see the MyCloud icon but I can’ access it.

Then I tried to map the hard drive by going to Go and then Connect To Server and when I clicked on the MyCloud icon, it happened the same thing, I can see the MyCloud icon, but when I click on it it doesn’t connect and after a while it says Connection Failed.

I already assigned a fixed IP address for MyCloud.

I’ve been having these same problems since I bought it last week.

I have been able to transfer about only 1.5TB in seven days having to restart and reconnect everything almost everyday.

And right now I can’t access MyCloud through the Network, through mapping the drive, mycloud.com says the device is offline, and the http://wdmycloud.local is not responding.

Again, your help will be appreciated.

Thanks!

Sounds like either you have some sort of network problem or the My Cloud is defective.

Who is your broadband/ISP provider?
What color is the front LED?
What colors are the back LED? Are they both lit up?
What model router is the My Cloud connected to?
How is the My Cloud connect to the router? Direct ethernet wire or through some sort of home power line or similar device?
How is your computer connect to your local network? WiFi or Ethernet?
What OS are you using on the computer?
Can you access the My Cloud Dashboard using the My Cloud IP Address?

Hello Bennor,

My broadband provider is Comcast.

The front LED is blue.

The back LEDs are green and they are both lit up.

The router is a NETGEAR AC1750 R6400 and I bought it 3 weeks ago.

The MyCloud is connected to the router through direct Ethernet.

My computer is connected to the network through WiFi.

I have a Mac with OS X and a PC with Windows 10. Same problems on both of them.

Sometimes I can access and sometimes not.

Oh, and right now I can access perfectly the MyCloud using the IP Address or through http://wdmycloud.local. But when I try to map the MyCloud as a network drive using the WD MyCloud software, the software can’t find the MyCloud.

Have you tried connecting the computer direct to the router using Ethernet to see if the problem persists?

Are both the computer and the My Cloud in the same local IP address subnet? For example are they both using an IP address in the 192.168.1.x range? If you have assigned the My Cloud an IP address within the Dashboard, change that setting to Auto and assign/reserve an IP address through the router’s administration screen.

If you haven’t already done so perhaps performing a 4 second reset or a 40 second system restore will solve the problem One does not loose their user data/files when performing a reset or restore.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

Hi Bennor,

I reseted the MyCloud and disabled all the options as suggested by SBrown.

I have the MyBook connected to my PC and now files are transferring incredibly fast compared with before, around 24 MB/s.

But I still have a problem, I can’t map the MyCloud as a Network Drive.

I downloaded the mc_windows_setup software to map it as a network drive, but the software can’t find theMyCloud, even though I am able to see it in he network, using the its IP Address, and I am able to transfer file from and to it.

Suggestions on what’s happening and how to map it?

Thanks!!

The following WD Support documents detail how to “map” a drive/Share on both Windows and Macintosh.

http://support.wdc.com/knowledgebase/answer.aspx?ID=2676

https://support.wdc.com/knowledgebase/answer.aspx?ID=2686

Your single Bay Mycloud has 2.21.119 firmware, the windows setup will not see it, but WD QuikView will.
http://downloads.wdc.com/nas/WD_Quick_View_Setup_for_Windows.zip

Hi SBrown,

I Installed the http://downloads.wdc.com/nas/WD_Quick_View_Setup_for_Windows.zip file, but after installing it, when I click on it nothing happens.

I uninstalled it and then reinstalled it again, and the same, nothing happens when I click on it.

I was able to map the drive using the link from Bennor: How to map a My Cloud or NAS device on Windows; Mapping a My Cloud device on Windows.

The mc_windows_setup can’t find MyCloud, and the WD_Quick_View_Setup_for_Windows doesn’t open when I click on it, but I was able to map the drive and I can transfer files without any problem.

Should I be worried about those 2 programs not working?

Thanks!!

Possibly Anti Virus, Malware or End Point Protection software preventing the startup.
I would just uninstall.

Thanks SBrown!