Problems seeing Media Server Windows 7

Ok I have this new WD TV Live streaming player (WDBHG70000NBK) and it plays my Windows 7 network shares and sees them just fine, but it cannot see the windows 7 media server at all.  However, I have an older WDTV Live Plus HD media player ( WDBABX0000NBK ) and it sees the Windows 7 media server perfectly.  Plays from it great too!  I have no idea what’s going on.  If I have to I will just stick with playing files over the Shared folders but I thought that since this one is a newer model, and my older model is working great, that I would expect this to at least do what the older one can.  I have them both connected via WIFI.

It appears you set up your old Live Plus correctly, and less so for your new SMP.  Perhaps you need to set up the Discovery Tool and read through the full online manual you can download.  Go to the support section for your particular player and find what you need there.

You know in all honesty I didn’t DO anything to setup the first one.  My windows 7 media server sees BOTH devices and BOTH are set to share media with …  as SOON as I select MEDIA SERVERS from my new WD TV SMP I get an error saying content not available.  I did read the manual and I didn’t find anything saying that I had to do anything special to get the device to see media servers…  However it is on the same homegroup as all my other devices, Windows 7 sees the device and is allowing media to be shared with it…  :confounded: no idea…

This is what I get when I select Media Server.  It just instantly tells me this.  Funny thing is that from Windows 7 I can right click on a WMV file and select PLAY TO and select my WDTV Live SMP and it will play the file on the SMP, but I cannot see the Media Server from the SMP?!  This has to be a bug… what else can be causing this!!!:confounded:

Can’t see your pic until it gets approved.  Nevertheless, you said you are using “homegroups”.  Well, the WDTV does not like homegroups (It’s a totally Win 7 “thing”, and non-standard with other equipment) and the WD needs it turned off in Windows and we need to use Workgroups instead.  Be sure ALL your devices that use Workgroups (such as PC’s, WD players) are all in the SAME Workgroup.  The WD defaults to the workgroup name of:  WORKGROUP, and most Win & PCs use the same name.  Just be sure your Workgroup name in all units is WORKGROUP.

A win 7 PC will show you this regarding the Workgroup name, and if it needs to be changed, you do it at this screen:  http://0.tqn.com/d/macs/1/0/D/M/-/-/workgroupWin500x488.png

Turn Homegroups OFF in Win 7.

Sorry I meant workgroup not home group. Yeah they are all set to Workgroup. OK now here is a strange thing it sees the windows 7 media server on my wife’s laptop but doesn’t see it on my desktop. One thing I notice is that her laptop name is 8 characters and my desktop is nine so I’ll try making it 8 and see if that helps. Shouldn’t matter but something wrong is going on here.

The laptop name has nothing to do with this.  You are grabbing at straws!

Unless some other user jumps in here to help, I think you need to contact WD support and they can help you while on phone, etc.  You have a new unit, so use your prerogative to contact WD support.

Yes I am grabbing at straws! LOL. Would I call them or email? What do you recommend?

Just phone them, its easier to discuss it.

mike27oct wrote:
Turn Homegroups OFF in Win 7.

You’re sure about that? I’ve never turned mine off and still can stream from my Windows 7 PC (which is in the same workgroup as my SMP).

petermg wrote:
Yes I am grabbing at straws! LOL. Would I call them or email? What do you recommend?

So just to throw a kink in all this… I have the same (or at least similar) issue and I have been working on it for A YEAR!

Yah, tis true. I have a PlayOn media server that I stream DLNA to my other devices. It is on a win7 server. I could always acess it from my Live+ and my ROKU but for some reason my HUB does not. Simply does not see it

Then three weeks ago I added an SMP to my netowork, and it sees PlayOn just fine! For some reason I cannnot for the life of me figure out, the HUB simply cannot see that win7 media server. And as in your issue, I can attach to shares on that server no problem, and the server sees the HUB just fine. It has had me baffled. I have done all the regular stuff, changed the ethernet port it was on etc but no luck.

Note: The HUB can see media servers on other computers, just not this one specific one. Also, I am running Plex on that same server which the HUB cannot see, so I have eliminated PlayOn from the problem. This is some funky stuff.

Sorry, not much help I did not mean to hijack your thread, but I wanted to commiserate and say that this seems at least to me to be a complex problem. If anyone comes up with an answer that solves petermg’s issue, I am hoping it solves mine. Luckily I have a Roku on that same TV so I still get all the functionality that I need. If not, this would have driven me insane by now.

Good Luck and hopefully your answer will solve mine?

-P

I wonder if there’s anything I could find regarding this.

some of you might remember the NFS udp vs tcp issue I found

I don’t use media servers often, so haven’t looked yet

serviio is running on my linux server

I did recently have some errors, but I think, my issue is more related to setup after upgrading my server OS

to Ubuntu 13.04

I think I need to edit my transcoding profiles

I’d probably first check what ports are open on the SMP and compare to what ports are needed by the media server

after that probably will need a packet capture

I should be able to fix my media server and capture a working stream

but I’ll probably need a packet capture from a system that doesn’t work to compare

Techflaws wrote:


mike27oct wrote:
Turn Homegroups OFF in Win 7.


You’re sure about that? I’ve never turned mine off and still can stream from my Windows 7 PC (which is in the same workgroup as my SMP).

TF, I am not “sure” of anything!  :wink:

I do know that it has been mentioned many times in these threads to not use Homegroups to try and share drives with the WD units.  I also believe that when I called WD support for assist with my new player years ago, I was told that having Homegroups ON was not necessary (could cause issues) and they also had me uninstall Windows Live programs (I still question THAT advice!)

Anyway, some of the forum “regulars” have now chimed in on this problem and can’t come up with a solution, so again to the Poster, CALL, don’t write, WD Support and get a live person to help you with this one!

SUCCESS!!! kind of.  I had my Windows 7 PC on a static IP, I changed it to dynamic then it showed up fine for the WD TV LIVE SMP.  So there is something that is different between the old WDTV LIVE PLUS and my new WDTV LIVE SMP since the older can see it on a static IP whereas the new one does not see it.  I’ll have to delve into this a bit more … wonder if it’s an IPv4 VS IPv6 issue or something else…?  

I hope this is it, although my router assigns everything on it to a same IP address  each time (based upon an algorithm) so, in a sense I have things on a static IP.  No problems.

Well, if you “admit” you have “tweaked” your router, etc, no telling what else could be amiss.  So, try to get your router as near to normal as possible again, and see what develops.  And, as I said, your problem is with something on that PC, and not the WDTV unit.  The WDTV appears to be the victim and not the cause of what’s amiss…

I didn’t touch my router. I had my Windows 7 set up on a static IP. My WDTV Live plus has no problem with this but for some reason the WDTV Live SMP doesn’t see the media server when I have it on a static IP. I’ll investigate this more later today or tonight and report back. Maybe there is something I SHOULD change in my router? Well see I’ll first try a few different settings on my windows PC.

OK, I thought you had to get into the router to set a static IP.  OK, so you did this on the PC.  No matter how it got done, it does seem, from what you say, that this has freaked out the WDTV somehow.  Think of other things you might have changed that could cause problems.  Great that you seem to have tracked it down, so far.

the fact that is works when set to DHCP

indicates something likely wrong in the router

possibly, even a firmware bug in router

or the static IP setup on PC has configuration errors

DHCP - router assigns IP to each device

and then resolves DNS request accordingly

on Static - PC request a specific IP address

if IP address is not already assigned router allows the assignment

and should start handling DNS request

it sounds like something is wrong with either

DNS handling

or possibly incorrect broadcast handling/forwarding for static IP address

OK… DRUM ROLL!!!

After a lot of testing, enabling disabling settings on my WIFI Adapter on my Windows 7 PC, the WDTV LIVE SMP will see my Windows 7 PC on a static IP so long as it is NOT above 119!!!  I’m on 192.168.1.x subnet.  If I set my Windows 7 media server to any static IP BELOW 120, the SMP sees it just fine.  Above it doesn’t.  Well I haven’t tested every address above 119 but I’ll leave that to someone else.  SO… if ANYONE else is  having a similar issue.  Give this a try, change your IP to one BELOW 120.  No idea why the SMP has this issue but glad I found a work around :wink:

1 Like

Great!  If you say it is fixed, it must be true.  Congrats!

I want to point out to others who may read this thread.  Our poster was pretty sure this was a “bug” with his new WDTV; as he said early on:  "SMP?!  This has to be a bug… what else can be causing this!!! :confounded:"

This quote is here not to put down our Poster.  He was gracious and accepted users’ help.  It is quoted to point out that too many people who have an issue with using their WDTV immediately show up here and blame the device, and some get pretty darn angry and diss the product and WD for a crummy product.  But, most often it turns out the device is fine, and it is some setting somewhere else in the system that is out of whack and causing the problem.

1 Like