Problems rollingback Firmware

I have firmware 2.01.86 and I would like to roll back to the previous one as I am having stuttering problem and losing audio. When i plu in my USB with the three files on the root it sees it but nothing happens. Please help

http://wdc.custhelp.com/app/answers/detail/a_id/5860/

I did try the instuctions that the link goes to but the USB drive can not be accessed when plugged into the WD box

Did you download the special firmware linked from that page?

yes and unzipped the files ro the root of the
USB

Open the contents of the VER file. What does it say?

VERSION=‘2.06.15_V’
LOCATION=‘wdtvlive.bin’
PKG_LOCATION=‘wdtvlive.pkg’
ROOTFS2=’’

You didn’t download the file from those links on the page I provided… That firmware is for a totally different system, the 2009 version of the WDTV.

I posted thewrong file

this is the right

VERSION=‘3.16.13’
LOCATION=‘wdtvlivegen3.bin’
PKG_LOCATION=‘wdtvlivegen3.pkg’
ROOTFS2=’’

Try a different USB drive, then…

Sorry for no reply need to pay the bills. Started from the beginning

Downloaded file extracted to root of three different USB sticks. Followed the instruction of booting up the box and plugging in the stick, the system sees it but dose nothing ( 3 different sticks same problem.

Tried both front and back ports same problem,

Tried one stick into each port at same time, same problem.

Did a soft reboot ( power button on remote. nothing

Did a hard reboot ( unplug box ) nothing.

Can these boxes be reset to the factory firmware that it was when I purchased the box?

Tips

1. Grab a small (2GB or 4GB) Flashdrive and format it   FAT32   Important

2. Download and Extract the Rollback Firmware files to the ROOT of the USB Flashdrive

http://download.wdc.com/wdtv/wdtvlivegen3_rollback_1.16.13.zip

eg. You should ONLY have 3 Files on your Flashdrive (NO FOLDERS)

wdtvlivegen3.bin

wdtvlivegen3.fff

wdtvlivegen3.ver

3. Before inserting the Flashdrive into WDTV SMP ensure in the WDTV SMP Settings…

Setup > System > Auto Detect New Firmware > ON

4. Power OFF your WDTV completely

(press and hold the Power Button on the Remote Control for 5 Seconds. Swtich off at the Mains Power afterwards to be sure)

5. Insert the Flashdrive into the Front USB of the WDTV SMP and then Power On

The WDTV SMP should now prompt you with a Firmware Update  3.16.13  

(This Number is Normal as Rollback Firmware must have a Higher Number than the current Firmware you a running)

_   _

_   _

_   _

1 Like

THANKS

That worked and the rollback fixed the issues I was having