Problems / Questions - 16 WD drives - WD1001FALS-00J7B1 & WD20EADS-00S2B0 & WD10EADS-65L5B1


#1

Hello - First time poster, but a LONG time WD buyer and need some help.

I have 16 WD drives in the 1TB BLACK & 1TB, 1.5TB & 2TB GREEN category and have some Problems / questions about a few specific drives & their issues:

GENERAL Questions:

1st - FIRMWARE - Can I download and flash any of these drives with new firmware? If so, how?

I have 4 x WD20EADS-00S2B0 - but with 2 different Firmware revisions - 01.00A01 & 04.05G04 - one difference I see for certain is APM is only adjustable on firmware 04.05G04, so I assume it is newer & better… can I update the older drives to this firmware or newer?

2nd - MFT zone size - I checked my drives that have been in use for about 3 months and found some unusual numbers. I confirmed my registry setting for the “MFT” is set to “2”, which I believe is 12.5%, however, on these drives (which are between 50% to 80% filled to capacity - approx. 10,000 files) Diskeeper is showing that the MFT is VERY small - 12 MB!!  one shows MFT  as 87% “Full” and the other drive MFT=11MB and 99% “Full”. Should they not be “self-adjusting” UP TO 12.5% as needed? If so, WHEN?!! is this normal or a problem?

:mansurprised:

SPECIFIC Problem: :mansad:

Model WD1001FALS-00J7B1 firmware rev. 05.00K05 

I am getting some SMART errors on this drive (C5, C6 with CrystalDiskInfo and C5, C7 with HD Tune Pro)

I also did an “Error Scan” with HD Tune and it found a few damaged blocks… will a format fix this? can I somehow set the drive to factory defaults and “fix” this???

I also tried running WinDLG on this drive 5 times but Quick Test FAILEDFAILED!!!!

Just now I tried it again and it got way passed where it failed before, so I was hopeful, but now it is just stuck after letting it run almost 1 hour!

I will start with those questions for now :wink: I look forward to getting clear info on whether I should be concerned or not.

I have already BACKED UP this drive, so I don’t care about data loss at this point.


#2

b b b b b bump!

Need help! Anyone have some input on this drive?!


#3

Concerning firmware updates for these drives, at this time there are no firmware updates available.  When you see different revision numbers, those are done at a factory level and are hardware associated.

Concerning MFT zone.  I’m not tech support, but I did a little research and found that the operating system should be responsible for allocating the needed space at the beginning when it’s first installed on the drive.  You shouldn’t be messing with it in the Registry.  The Space in the zone will diminish over time, as more and more data is saved to the computer, and that’s normal.   Here are a couple of links that talk about it, and you should read them thoroughly.   Just know that as you hit the 90% and above for data storage you are probably already cutting in the MFT Zone and that can effect drive effeciency.  Of course the more data you have on the drive, the more time it will take to access it anyway.

http://support.microsoft.com/kb/174619
http://www.pcguide.com/ref/hdd/file/ntfs/archMFT-c.html

Now, concerning smart errors on the Caviar Black drive.  Smart errors indicate that the drive is failing.  You should get the data off the drive and replace it.


#4

Thanks for the reply :smiley:

Firmware: No problem - I was just curious if there were any recommended updates I should do, I just wanted to avoid any possible issues by being fully informed by the WD Community :wink:

MFT: Thanks for the input, I have a good idea of the MFT zone now, but want to confirm what I am seeing is normal and not going to lose my data by the MFT being ‘Full’ when it is only 11mb!

Average file size is 10mb (Flac music files)

I would love to hear to WD Tech support with any input they can offer.

And of course, is the Black 1TB mentioned above dying? It passed the WD Extended Test, but errors on the WD Quick test.

Can those bad sectors be recovered?

Thanks to all :slight_smile:


#5

Sharkmanbmw wrote:

 

It passed the WD Extended Test, but errors on the WD Quick test.

Can those bad sectors be recovered?

 

    • *> Quite possibly, yes.  My drive was throwing new bad sectors every month or so, usually causing a file to be lost, and the Quick Test gave a similar if not the same error - and passed the extended test, just as yours does. Running CHKDSK would result in increasing number of bad sectors.> I formatted the drive in the end, and since that, it has been fine. The SMART has stabilized too.> Why a format fixed it, I can only speculate. Maybe since it is was originally done, the drive had “settled in” and needed to be “recalibrated”. Anyway. This was the thread …
      community.wdc.com/t5/Desktop/Data-Lifeguard-reliability/m-p/15444>

#6

Hi, I used windlg to perform the “write zeros” test in the full mode, it finshed and then I ran HDTune and did and error scan. This time, I have just ONE bad sector left!

So, I am running write zeros again hoping it will fix the last bad sector, then I will just keep an eye on it to be sure they don’t come back.

Will post back how it turns out :wink:


#7

Update: After running the write zero test again, I still have that one bad sector :frowning: Any suggestions how to get this fixed? Which app should I format with? any ideas are appreciated :slight_smile:


#8

update 2

Had to use HDDRegenerator to fix this.

Ran it from CD and it detected the same single bad sector and was able to recover it, so the drive is showing as OK now.

Pretty annoying the WD software cannot fix it’s own drive but a software I have to pay for can :confused: At least I have learned how to handle this in the future…

I have 20+ WD Black or Green drives and I was really concerned that WinDLG couldn’t handle the job.