Problems my cloud 4T

Hi, I haver my new my cloud 4 T and until now it’s not a great experience. Here are my problems:

  • very slow speed, 2 m/s, i will work probably a month to transfer all my photos, movies, music, etc. It takes 6 minutes for a 700 m movie ! 

  • some of my personal movies are not played by my tv. Two movies, filmed by the same camera, same format, almost same size (150 M), one has image and sound, another just sound, don’t know why. On my PC the two work fine.

  • when I load a personal film over 1 Gb, the upload stops at 999 Mb and after a few second continues or restarts from the beginning.

  • I give a link to another person for one of my folders, his download is at the ancient dial-up speed, 1-2 Mb/minute !!

I don’t know how to solve all these problems. Maybe WD is great as HDD (I have another 3 My Passports) but My Cloud doesn’t make his job at all.

Is the NAS connected to your router through gigabit Ethernet wire? Is the computer also connected this way?

How are you putting content on the NAS? Hopefully through mapped network shares?

I am experiencing similar problems… 

Interestingly I am currently running method one in the background as I am writing this and the file transfer does continue after the 999mb point. However the file is transferred in chunks. so to 999 mb and a 5-10 minute break then it continues to 1.95GB and a break. Then 2.45GB and break. How come it is unable to maintain a steady transfer speed?? With the fractions becoming smaller and smaller. 

I have tried two different methods of file transfer. 

1: Through the WD desktop app. I copied a file in windows explorer. Then either drag or right click and paste into the desired folder. 

2: connecting through run: with \MyCloud and from that drag and drop/ copy paste into the desired folder. 

I tried to connect the WD cloud directly to my computer through the ethernet cable from the box but no connection is happening. 

The computer is wireless and the NAS is connected through the cable that come with the box…

Wireless is absoutely useless for transferring files onto the nas. I get <5Mb/s wirelessly to my macbook pro. Via ethernet however I can achieve anywhere between 37-50Mb/s

Hmm…  sounds like I should do further investigations into a wired setup then… anywho… 

The problem currently remains the same. The transferspeed doen’t increase when the setup is connection through wire… so currently: 


I guess this is how it should be? Any optimization suggestions? :) 

what are the lights by the Eternet cable doing?

try file explorer/finder instead of the mycloud app for LAN use, for remote access the mycloud app seems to work better

hmmm… interesting… When I copy/paste files into the explorer menu when wireless I get roughly 4 MB/s equivalent of my internet connection, however when I connect the computer directly to the router a linksys E900 (N300) the transfer entirely stops :frowning:

the lights on the etherned port are red/orange and flashing green. no matter if computer is wired or not.