Problems mapping drive and accessing private shares

Been using My Cloud happily for years now. I recently had to refresh my computer and deleted everything and now trying to map my private share (attached to my admin account) in Windows 8 with no success. It’s asking for a password but my admin credentials don’t work (they did before). I logged in online to manage users and realized that I can’t manage or reset the password for my private share without doing that for admin access.

How do I map this drive then if I don’t have an actual password for my private share? None of the instructions here has worked so far.

What have you tried? Do you have Quick View, if you have it. See image below. Right click on Quick View to bring up menus.


Have you accessed the Public share?

If so, you will need to delete all credentials associations with the MyCloud (use Windows Credentials Manager), and re-connect to the MyCloud shares, providing your MyCloud credentials for every share you try to map, even the Public share.

This is a Windows problem.

So even after removing all the credentials, my login info doesn’t work to connect to my private share. So weird. I can access my public share fine, no credentials needed apparently.

Can you post the exact error message or post a screen shot of the error message you are receiving when attempting to access a private share?

Did you reboot your PC after deleting the credentials?

Did you force the use of your MyCloud credentials for every share you tried to access, including Public?

If you have forgotten your password, a 4-second reset will clear the admin password.