Problems copying video files


I have the my cloud connected to my router and inside the netweork everything is running basically without any problems. By the way I am using currently Windows 8.1.

When I connect from a remote network, I can also connect to the device and also access the data on it.

However, I have trouble copying big video files from a remote network. While I can copy these files to the device, while in my home network I do not encounter this problem.

It is also hard for me to find out the cause of the problem, since it does not applies to all video files, although most are affected. When I try to copy one of these video files (normally mkv format) via the WD my cloud desktop app it starts to copy the file, but at around 50% stops the process and just gives an error message that the file couldn’t not have been copied. When I tried to map the drive to copy the file just via the file explorer, the process seems to work and also the status bar runs to 100%, but after it has reached 100% it never stops.

Any ideas what could be causing this problem? It seems also strange that not all files are affected.

At what file size do the copies begin to fail?

I expereince this problem with video files of all sizes. Yesterday I tried to copy a mkv file, which is only 550Mb in size and it stopped at around 50%. It seems to doesn’t have anything to do with the file size, as I was also able to copy 8GB files without a problem.


What version of the desktop app are you running?

Which NAS device are you using?

Are the finals that fail always mkv or have you seen other types failing as well??

Greatly Appreciated!