Problems connecting to network shares

I have had some problems connecting to network shares off and on since i got this four years ago but recently I have been having problems much more frequently. Running network setup used to work but now it doesn’t. Unplugging it for a couple minutes used to work and then when that stopped working I tried restarting my PC and unplugging my router and modem all at the same time, which worked for a few times but now doesnt work reliably. Im sick of that method anyway and would love to know why network shares doesnt work but media servers does, always right away. Sorry for jumping in here, I just think we are having the same problem and really want a solution.

[MOD: Moved to dedicated thread]

Hello, As a recommendation, try setting a static ip on the unit as this will improve the connectivity. Also see if the following link helps.

OK so I turned off Homegroup and ran the master browser script and my PC is my MB. I did notice that the script did not work until I restarted my PC so I think there may be something with my PC that is causing this. When I cant connect to network shares if I go run the script to see if im no longer the MB, I get the error: “The list of servers for this workgroup is not currently available”. When I restart the PC the script works and I can connect (also have to restart the WD after PC is back up tho).

I saw at the end of Tamxir’s long ranting thread someone suggests making the router the MB. if that will solve my problem I am all for it. How do I do that? Also, you suggest making “the unit” have a static IP, which I assume you meant the WD, but I dont see an option for static vs dynamic in the settings. Thanks for the help