Problems after pressing video to play


I have recently been having intermittent issues with the controls after I press the play button to start a video. Sometimes it takes too long to start and do anything and I have to restart the device. I have also even tried to reset the device to factory default to no avail…

Sometimes, after I press play, it will start the video but then I cannot control the fast forward and backward.

At other times,  when I press on the ok button to show the time progression, you will see the time at 00:00.  It will continue to play but I can’t control it anymore.

I was wondering if anybody can help me. I know some people will say to reinstall the firmware ( but I don’t know how. Maybe somebody can help. Can I also rollback the firmware? I can’t seem to find the old firmware.

Any help would be appreciated.



I’ve had this problem two or three itmes in the last  few years

The only thing that has solved this has been a cold reboot - that meaning removing the power cord and letting the power cycle out of the unit for 30-60 seconds and the replugging the unit in. 

I am at firmware 1.6.13 (I reset  back to 2.01.86) about 6 months ago.  

To rollback, you can get old firware here at

Put the firware on a USB or stick drive and reboot the WDTV with the USB inserted. It will do the firmware reversion

Thanks. I guess I will just have to do that then.


I have rolled it back to 1.6.13 and the behavior is still the same.

For now, it seems that when I play the first video, it will work fine for the next 20 minutes but after that somehow the progress timer resets itself to 00:00 and I can’t control the media player any longer.

Should I have the device checked? Should I even bother having it checked? Should I just get a new one?



There is a problem though with the NAS I am streaming from. One of the disk is startiing to fail although the media I am playing from is the good disk. I haven’t removed the other disk yet simply because I am trying to copy the data over to a new drive.

Should I remove the other disk and see how it plays out?


Why don’t you copy a video to a USB or stick drive and connect it to the WDTV and see if it freezes (or has the same behavior you are complaining about)

Then you’ll know if its the NAS behavior or a WDTV Issue

BTW, what types of files are these - MKV, AVI, Mp4, VOB ???

Sounds like a plan. Thanks! I geberally have .mp4 files thought I will have the occasional mkv or avi files…

@Ansj64 did you ever find your solution to this? I have similar issues and it seems to be related to having certain PCs on the network turned on, etc…