Problems after FW upgrade: WDMYCLOUD


#67

Definetly not a problem on my computer. Anywhere else on the Dashboard UI times display correctly.

On a whim I tried out My Cloud’s email Notification. When My Cloud generated a Notification the email copy indicated the correct time while the copy on UI Dashboard was still 3 hours ahead.


#68

Surely WD have a plan to be able to rollback the firmware if the new firmware breaks everything.

It’s been 3 weeks now, and I can’t stream music. I get 177KB/Second speeds copying. It takes 10 to 15 minutes to login to the cloud.

It constantly shows 0% in QuickView.

I can’t access the cloud remotely.

I’m trying to backup the data that’s stored on it, but it’s going to take days.

What is Western Digital’s solution to fix this problem?


#69

@MinusSeven

Can you log in remotely via SSH? Will the system mount a USB drive? If it’s a network issue your box has it may be quicker to copy your data to a disk attached to the My Cloud’s USB port. If you can access the server vis SSH you can run some checks yourself, if you are familiar with Linux. (If not, I advise extreme caution)


#70

Trying to copy to the USB drive connected to it. 136 KB/second.

Everything was working fine until the firmware upgrade was complete. Now it’s useless.

I can’t do anything that I bought it for. 3 weeks since the firmware was released, seems everyone is having issues, and no fix.

I’m just wasting hours of time on this. I’ve tried everything to fix it.


#71

I might take it back to the store and see if I can swap it with one with an older firmware installed.

I’ve had it since about 8 months now, but surely if it doesn’t work, they would have to swap it, or refund me.


#72

I can’t even backup whats on it, it’s so slow, and keeps stopping.


#73

What does WD say? I realise they can’t log in if you have no cloud access, but what have they suggested? Have they requested the logs? Also. have you tried to diagnose it yourself, i.e. check what it’s doing, how much memory it’s currently using, check the logs, etc.? Is it continually scanning, btw? I have found it to be slow while it’s scanning, so I’ve disabled it and I enable it only after I’ve made changes to my media. Also, have you excluded all your data from the media scan? If not, it will spend ages scanning your data when you simply add a file.


#74

For 2.3 TB of data it took 6 days and 7 hours for the scanning. Now i will disable everything, including remote access and will see if it functions well as simple NAS.


#75

They requested the logs. But it took about 2 days to produce them. They told me the firmware needs reinstalling. So I did that, and no change.

I just can’t spend anymore time on this.


#76

I was copying 1.5 Tb of data to the USB3 drive directly connected to WD My Cloud 4TB (latest firmware).

It took almost 100 hours to complete everything. Drive was disconnecting and the speed was 3Mb/s - 12Mb/s. Even when I disabled all the scanning and indexing.

Now I just want my money back.  I scheduled a tech appointment but the line cut off and I never received the call again!

What is it? This is becoming a nightmare! What supposed to help organize my digital life is now sucking my time and energy. 

How do I return it ASAP? 


#77

I had the same problem.  I called tech support, they had me do a “system only” restore (doesn’t impact data, but wipes out your users).    

I still can’t transfer data to mycloud, but interestingly I can transfer data off the cloud.  So I backed up everything to another external harddrive.   Since the issue wasn’t fixed they are sending a new piece of hardware.  I’m pretty sure they know they have a problem with the new firmware release and something is not compatible with the “older” hardware out there.

My system worked great until this point.   So hopefully the new hardware will work.

good luck


#78

Hello All. Ok  heres the deal I bought my cloud about 5 months ago maybe less. I take it out of the box set it up let it do all of the updates. Then I start backing up all my data to the drive approximately 250 gb mostly small files so my transfer speeds weren’t that great some times 16mbs/ all the way down to 1 kbs it never ran consisteantly constantly kept falling of the net work iphone app would connect sometimes and some times not. I was beyond frustrated so I decided to transfer all my files that took almost 2 weeks to transfer to the drive back off so I could smash the cloud with a hammer… Not really.

I decided I was going to do a full restore on the drive (i had tried the simple system restore to-no-avail) Well it took me another two weeks to recover my data then I did the Full Restore it took about 12 hours or more to do. I got everything set up users shares ect I started to transfer my files back (movies) I have 85gb it took one hour! I set up my phone apps they work flawless thumnail generation fast the difference in the operation of this drive is night and day. I had almost all the same problems everybody else had tried almost everything that was sugested nothing worked. This drive works better than it did out of the box my firmware is v04.00.00-607. 

So my thinkng is this: The linux operating system combined with the automatic firmware up grade out of the box set some kind of confict with  linux and the firmware. So if you buy a new my cloud set it up do the firmware upgrades then before you transfer any files to the drive do a Full restore so that the operating linux system can do what ever it needs to do to incorporate the new firmware. I just think theres a confilct.

Hope this helps other frustrated wd my cloud users. If this solves your problem click on solved. 


#79

hi guys,

i just got my wd mycloud fixed by WD. looks like everything is working fine for now. people from WD advised me to just let the device sit for sometime and let it finish indexing my files. if you really have an issue with your mycloud, create a support case and WD will take care of you. i saw how they fixed it. if you don’t care about your warranty i can show you how. ill just finish reading the guidelines so i know if i’m gonna violate anything for sharing something.


#80

@lloydcruz

I’m pleased that you have finally got somewhere with your device.

Thanks for your advice to raise a support case. Unfortunately, that’s exactly what I’m about to do! Mine has been working fine up till now (on the latest firmware) but I have been try to back up large amounts of data using the USB port, thinking it would be quicker than the network. Across the network (Gigabit) I get 6.7 MB/s, copying about 7,500 files totalling 10GB in about 14min 30 seconds. Connected via the USB 3.0 port on the MyCloud I almost get USB 1.1 performance, taking 22 minutes at a rate of 7.9MB.s to copy the same data. Slower than the network! My PC copies the same data at 52.8MB/s in 3 minutes 9 seconds from the same external USB disk that was used on the MyCloud.

Sometimes now, while copying, it will simply stop, continuing after a minute or two later without reporting any errors. Also it slows to a crawl, amd then fails to copy every file stating “Permission denied,” asking me to cancel, retry or skip. Retrying eventually returns to offer me the same options and results in a directory full of files which are all 0 bytes in size. Not an ideal backup solution.

For what it’s worth I waited until scanning had completed, turned off DNLA and turned off the scanning in the Twonky web interface. Sadly, the WD software overrides this and it scans immediately it is written to - even just one non-media file written to an area which is not included in the scan! Crazy.

Logging in to the UI is now slow. It takes about about a minute for the login page to show and another 30 seconds to process my uid and password. :confounded:

There are no related errors in the dmesg log or in /var/log/messages. This all happened when I was copying and it looks like the database crashed, and I got this:

I left it overnight to rebuild but it hasn’t been the same since.


#81

I can try a factory reset. But I’m having trouble backing up what’s on the cloud. It keeps losing connection, says it can’t find the file. Even though I can open it.


#82

@scooby

what they did with mine is pretty simple. it was really simple even i can do it. they requested me to download my devices previous FW and asked me to insttall winscp. they remotely controlled my pc and did a FW rollback. the rollback was really simple. i just don’t want to post it right here as the procedure might not work on everyones mycloud. so i suggest you follow their instructions and have a little patience.


#83

I was reluctant to change firmware on my in case I voided warranty. So I contacted WD Customer Support and asked either they change my FW or RMA me a unit. Was told not that it was NOT possible to roll back the FW so I’m waiting for my new My Cloud. Have since been told by WD that Customer Support agent was wrong. 


#84

@lloydcruz

Thanks for the info.

I updated my support case yesterday but no-one at WD has acknowledged it. Things here have gone from bad to useless. It looks like it will take about 24 hours to copy 90GB of data from a USB 3.0 disk connected directly to the MyCloud. It was producing network errors, file errors and all sorts of rubbish on the UI. During the copy it has said that some files were unavailable and I’ve had to skip them (retrying failed).  At times it has disappeared from the network; it has failed to maintain its own clock; it has produced errors when I tried to check the firmware status; it has said there was 0KB free space on the disk when a df command showed it was only about 10% full; finally, and mainly, it is incredibly slow to copy and spends most of its time asleep (meaning I can’t access it, which is how it is now).

I’m pretty sure the database is corrupt (the content scan just has a dash) and it would appear that the OS is too. I’m reluctant to power it off as it is obvious from the disk clattering away that it is as busy as **bleep** doing something.

I also tried to request support from the UI’s Support link, where I tried to attach a diagnostic report but I think it failed. I got returned to the login page, and as I never received a confirmation email I guess that it couldn’t even do that… Attempts to log in over SSH fail too, with Putty reporting timeout errors.

So my MyCloud is as good as useless. Should I post all my screenprints of the errors to try and shame WD into action?


#85

Update:

I got an email from WD Support requesting diag reports almost immediately after making my last post. However it’s busy at the moment (disk clattering) and doesn’t respond to much on the UI. I advised WD I would send a report as soon as it decides it has time to provide one. At the moment, when I request one it just dims the screen for a while and then asks me to log in again…


#86

After persisting with the WD firmware and being under the delusion that WD would fix it, I have finally given up and I now run it with a basic level of Debian, with no WD software running at all. I followed Fox_exe’s instructions here.

To anyone interested, I use the My Cloud as a replacement for Dropbox and I have 2 PCs here. Some days I need to upload ~200 photos and sometimes need to edit them prior to uploading to the web. The scanning process that ran got its knickers in a twist, crashing the database and initiating a rescan. During this time it dropped off the network, sometimes for several hours.

To those who point out that I have invalidated the warranty I say “Which is better? A device with warranty that doesn’t work properly, or one without warranty that does?”