Problems activating remote access of WD MyCloud


I’m having a lot of trouble getting the remote access to my WD MyCloud to work.

I bought this a month ago, and I’m still trying to figure out what to do… I’ve read this community upside down trying to find a solution, but I’m stuck…

So here’s the story:

Every time I try to activate cloud access, update my email, get a code, whatever, I get:

Device not registered. (400143)

The device is setup with static ip, I’ve configured port forwarding on both my router and my WD MyCloud. Under Settings/General/Cloud Access the connection status is saying Ready.

Yet, that doesn’t help anything…

So, I thought my device, for some reason, were not registered in WDs systems. So I tried to register a new device. I put in all the details, but got the message: “Device already registered”.

So, then I thougt that something might have gone wrong when I registered my account. I went to, and tried to register a new account, using my email. “E-mail already registered”.

Then I got back to my dashboard, and figured that if email already is registered, then I should be able to update my email in both “User” and “Cloud Access”-panels. But no; “Device not registered”.

So then I tried to go Entered my email and password - nothing. Clicked “Forgot my password”, entered my email: “The email address you entered is not associated with a account.”

So this is when I’m giving up… If anyone has a solution that actually works and actually will help me get cloud access to this HD, then I’d be a very happy man! I’m fed up trying to get this to work.

Please someone - what the f*** am I doing wrong here???

1 Like


Make sure that remote access is enable on the dashboard of the unit. If is already on, try contacting WD Support directly to check the units information.

WD Contact info:

The online support for this device is by a very wide margin the worst that I have ever encountered. No overview of setup instruction is given. I wan to access the dashboard: every time I try it says “administrator access” is required but I am the administrator. The answer given above to the very reasonable query is totally unhelpful if there is no way to access the dashboard.

It’s a perfectly reasonable answer to give to the OP, since it’s clear that they can access the Dashboard. It’s a specific reply to a specific question. It may not be the answer to your specific question.

From the sounds of it, there is something amiss with their device that does require attention from WD’s support line. Or a 40 second reset.

If you can’t access the Dashboard, that’s a different problem. Have you created an admin user, and given it a password? You need to use the username (not the email address) and the password.

If you have forgotten the password, do a 40 second reset, which will clear the users, reset the admin name to admin, with no password.

If you don’t know how to do a 40 second reset, or setup the device via the Dashboard, download and read the user manual. If you don’t know where to find it, Google ‘MyCloud user manual’.

Well… it suddenly works… I did nothing, changed nothing… It just worked all of a sudden…

So now I can happily access from everywhere. So I guess this one is SOLVED.

Same problem, please help…