Problems Accessing My Cloud Dashboard

Good evening all,

I’ve just bought a 4TB My Cloud personal storage and I’m having difficulties accessing the dashboard.

I use a MacBook Pro 2014 and I’m running OSX version 10.10.1

Both my partner and I have each registered an account on the cloud and I’ve dowloaded the dashboard software, along with all the other software downloads, to my MacBook.

When I launch the dashboard, the log-in window appears and prompts me to enter my log-in details. It seems to default to my partner’s account, not mine, but I enter their password anyway and momentarily, I’m taken to the dashboard screen. After a few seconds, I’m suddenly kicked out of the dashboard window and returned to the log-in screen, which asks me to log-in again. This happens again and again.

I’ve tried logging in to my account, but a message appears saying the account details are incorrect, which they are not!

Nevertheless, both mine and partner’s devices are backing up, via time machine to the cloud.

Does anyone have any suggestions as to why this might be happening?

Thank you in advance for your replies,


Hi helgamelgas, welcome to the WD Community. Have you tried using a different web browser to access the dashboard? You can also click on the following link to review the steps on how to access the My Cloud dashboard. 

How to access the Dashboard on a WD My Cloud, WD My Cloud Mirror, EX2, or EX4 Personal Cloud drive

only the admin user can login to the dashboard, it should be the 1st user created and have a a green checkmark in the users screen

I have not had any issues getting kicked out however it seems to be a fairly common issue, search on “access dashboard” should give you a starting point