Problem writing to a folder shared WD ShareSpace

WD ShareSpace

firmware updated.
old folders are not allowed entry, the attachment is allowed
in the new, too, with full access too, I can not write
What to do?

Can you reset the permissions on your Shares back to enable “Public Access”?  If so, you should be able to regain access to your drive’s shares using the “admin” login and password.  What operating system does your computer use?

I seem to have a similar problem ever since I upgraded to the latest firmware version (2.2.9) yesterday.

Upon mounting an NFS share (I created fstab entries) the owner of the mountpoint-directory changes from root:root or <user>:<group> to root:<different group>.

Identical users (by name) exist on the client as well as the NAS. I have no way of checking their IDs since SSH access also doesn’t seem to be working on the NAS (yes, it is activated).

I have no write access to any NFS mounted directory, not even as root (even though root is supposed to be the owner).

Up until upgrading the client system would retain whichever owner and permissions I defined for the mountpoint-directory. I made NO changes to the fstab file (or any changes at all for that matter). But ever since the firmware update the owner and access permissions change upon mounting. Once the filesystem is mounted these permissions cannot be changed using the chown or chmod commands.

ShareSpace Firmware version: 2.2.9

4 TB version, Raid 5

Client is running Ubuntu 10.04

Thanks

Update: I’ve got SSH to work. There was an issue w/ the RSI key.

I found out that the user IDs of the PC users and the ShareSpace users don’t match. I’m not sure if they matched before the Firmware update, but there was no access issue so I never had a reason to check since it all worked.

On my Ubuntu PC I have a user ID of 1000. On the ShareSpace the user ID for me (same user name) is 502. In the meantime I have been using FTP to copy or create files and directories on the ShareSpace. When I check the file properties in NFS, then it shows that every item has the User ID 502 attached to it and owner is identified as “unknown”. The group owner still shows my user name.

On Ubuntu, being a Debian based system every user ID below 1000 is a system user.

I wonder if, as a work-around I could just USERMOD my users ID on the ShareSpace and match up their user IDs. Has anybody tried this? And why would I have to do this in the first place? It worked fine earlier this week, before the new firmware came out.

Can you modify the shares on your drive by re-enabling “Public” access?  If so, can that access your drive’s shares again?  Do you use anything other than Ubuntu to access your drive’s shares?

I should have mentioned that. Already tried it with the same result: owner “502 - user #502”, group “mario” (my name).

And even if it did work, I don’t want all shares to be public.

I even created a brand spankin’ new public share from scratch. Same result: no write access, just read-only.

The only other computer client that accesses the ShareSpace is a WindowsXP PC, but only through FTP. This Windows machine is a notebook computer that’s on a (work) domain and refuses to find Samba shares.

I stream to a PS3 but that connection works fine but it’s read-only anyway.

Unfortunately, it sounds like the drive’s operating system is malfunctioning.  If you can access your drive’s data via FTP, I recommend that you copy your data off the drive and then perform a Restore Factory Default.  This will reconstruct the drive’s OS and shares but then you should be able to reload your data onto the drive afterwards.

helped the ‘Factory Default Restore’

I haven’t tried yet. I’m still in the process of moving stuff back to my external HDs. It’s a lot of work to find finding this much leftover space and I don’t want restore everything from my DVD backups. Plus the ShareSpace is not known for it’s superfast speed (even though I did discover, that if I run 3 or 4 simultaneous FTP connections I do get more than 100 Mbit/s out of my Gigabit connection)

if only WD was more open with their hardware!

Hi,

I and two other friends have these WD ShareSpace devices:

A) 4 TB WD ShareSpace WD40000A4NC-00
B) 4 TB WD ShareSpace WD40000A4NC-00
C) 2 TB WD ShareSpace WD20000A4NC-00

After upgrading all three devices, with update 2.2.9, I have been experiencing trouble using 2 functionalities on device A) and B). The C) device seem to be working.

The 2 functionalities that are not working are:

I) NFS:
After upgrade on device A) and B) I cannot use read-write mode over NFS. Read-only is working just fine. I have tested many mounting methods (manual, via fstab and auto mount) on many “distros” (Fedora 11, 12 and 13 and CentOS 5.3 and 5.5) but that does not seem to do the trick. This is however working fine on device C).

II) FTP:
After upgrade on device A) and B) I cannot connect via ftp and the following error is given:


Status: Connecting to 192.168.1.3:21…
Status: Connection established, waiting for welcome message…
Response: 220 vsFTPd 2.0.4+ (ext.3) ready…
Command: USER admin
Response: 331 Please specify the password.
Command: PASS **********
Response: 230 Login successful.
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Features:
Response:  EPRT
Response:  EPSV
Response:  MDTM
Response:  PASV
Response:  UTF8
Response:  REST STREAM
Response:  SIZE
Response:  TVFS
Response: 211 End
Command: OPTS UTF8 ON
Response: 200 UTF8 option is On.
Status: Connected
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/”
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 500 OOPS: child died
Command: PORT 192,168,1,120,140,64
Error: Connection closed by server
Error: Failed to retrieve directory listing

It does not matter if I use FileZilla or just built in tools in GNOME (Fedora 11, 12 and 13 x64 or CentOS 5.3, 5.4 and 5.5 x86/x64).

The problem appears to only exist on the 4 TB version, i.e. A) and B), but not the 2 TB version, i.e. C).

I have a 4TB WD ShareSpace and I took some time this morning to test FTP access using Ubuntu 10.10.  I found that the command line FTP client worked perfectly as did Nautilus.

With the error you’re getting, this sounds like a configuration problem with the ShareSpace itself.  If you’ve modified any of the system files, this can adversely affect firmware updates.  I recommend copying all of the data from one ShareSpace and doing a factory reset to see if that will reinitialize the FTP service configuration.  If not, you’ll need to replace  the ShareSpace.

I have not modified any of the system files. I have only changed settings on the device through the web interface. How should I replace the device?

So I did the Factory Default Restore and it worked … fixed all my write access problems under NFS.

However, I wish ShareSpace would elaborate a little on what it’s going to do and how long it’s GOING to take before you start. The restore procedure takes 16-17 hours on my 4TB unit!

And if you try to restore YOUR saved settings after the restore it starts all over and takes another 16-17 hours!

So in order to save yourself a whole day, I would try a Full Restore right away.

Hi,

After copying all my data to other data store, which took a lot of time, I did a factory reset on device A) and B). That solved the NFS write problem marked I) below.

Problem II) is still unsolved i.e. ftp. I tried to ftp to device A) and B) with FileZilla and the result is below:


Status: Connecting to 192.168.1.1:21…
Status: Connection established, waiting for welcome message…
Response: 220 vsFTPd 2.0.4+ (ext.3) ready…
Command: USER admin
Response: 331 Please specify the password.
Command: PASS *********
Response: 230 Login successful.
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Features:
Response: EPRT
Response: EPSV
Response: MDTM
Response: PASV
Response: UTF8
Response: REST STREAM
Response: SIZE
Response: TVFS
Response: 211 End
Command: OPTS UTF8 ON
Response: 200 UTF8 option is On.
Status: Connected
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/”
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 500 OOPS: child died
Command: PORT 192,168,1,11,196,97
Error: Connection closed by server
Error: Failed to retrieve directory listing

And


Status: Connecting to 192.168.1.2:21…
Status: Connection established, waiting for welcome message…
Response: 220 vsFTPd 2.0.4+ (ext.3) ready…
Command: USER admin
Response: 331 Please specify the password.
Command: PASS *********
Response: 230 Login successful.
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Features:
Response: EPRT
Response: EPSV
Response: MDTM
Response: PASV
Response: UTF8
Response: REST STREAM
Response: SIZE
Response: TVFS
Response: 211 End
Command: OPTS UTF8 ON
Response: 200 UTF8 option is On.
Status: Connected
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/”
Command: TYPE I
Response: 200 Switching to Binary mode.
Command: PASV
Response: 500 OOPS: child died
Command: PORT 192,168,1,11,183,151
Error: Connection closed by server
Error: Failed to retrieve directory listing

Best regards,
Kristjan

Hi,

I couldn’t access a folder. OSX gives me the errors I already told you about. Today I tried to access via FTP. Thought, that a different protocol may cause different results. But its the same. I’m still not abe to open the folder.

Is there any possibility the change the permissions of that folder? Win 7, OSX and FTP are declining to change the permissions. I use Cyberduck as FTP client and attached you 2 screens. I hope that they may help you to get closer to the problem.

The permissions are set to: rwxrw-rw- (766)
All the other folders are set to: rwxrwxr-x (775)

In the permissions tab on lines Group und Others “Execute” is unchecked. And “Write” on line Others is checked. This is also different from the other folders.

I couldn’t find an option in the web interface to change permissions for folders of a share.

Any ideas?

Here 2 screenshots of the folder informtion in Cyberduck:

cyberduck_1.png

cyberduck_2.png

I don’t know if this is related or not, but I have a 4-person workgroup setting using a 4TB  WD ShareSpace unit.  They’re having an unusual problem - folder locking as opposed to file locking.  When 1 user opens File “A”, regardless of its type (.pdf, .doc, etc), no other documents in that folder can be opened - the Windows XP/7 errors indicate locked for editing and files can be only opened as read-only.  Other folders can be used successfully, but only by 1 user at a time.  How do I get around this?  They are working as a team so they are constantly in folders simultaneously, working on different pieces of their projects.

I had this issue but was not willing to move over 2 terabytes off of my unit to fix file/folder permissions. I used SSH and connected to the NAS unit. I then did an su root and provided the welc0me password. I then did an ls -l command for /DataVolume and found that nothing had write access for non owner non group users. I used chmod to change the permissions I wanted to include write access. I also changed /etc/exports to not move all access to the high user and group id. This fixed my issues. I can now mount the folders in rw mode. It was a lot of work figuring this out and I had problems because I could not find an editor on the NAS operating system. I ended up using a cat command, cut and pasted into an edit session, did my changes, ftp’d the file to the NAS box, and then copied the modified exports file to /etc. Hope this may help someone else who is having issues. It seems crazy to me that a box using a Linux operating system can not speak to other Linux operating systems but does well with Windoze.

I fixed the ftp logon error by…

  1. Log on to WD ShareSpace Network Storage Manager
  2. Select Advanced Mode
  3. Go to Network
  4. Select Services
  5. Remove check in box in front of Enable under UPnP for Web Access & FTP

After that I could log on via ftp from FileZilla on Linux, Windows and also use native ftp client within both OS types.