Problem with WD7500AALX ... or not

I have a Dell XPS 210 with 2GB memory, running WinXP-SP3, just shy of 5 years old. The original drive was a 500GB Seagate (ST3500630AS). with1 primary partition cut up into 3 drives (C, D and E). A couple of weeks ago, the system started acting weird; it would intermittently freeze up for 30 seconds or so. Then it started blue-screening (mostly 0x7B), and on reboot, chkdsk would run and find problems on C: that it would claim it was fixing, (no issues on D or E). I managed to backup the D: and E: drives, but all attempts of backing up the C: drive or copy its files to another drive fail with a BSOD. I ran system disk diagnostics from the utility partition and it reported many unreadable blocks.

So I figured the drive was bad, and I bought a WD7500AALX as a replacement. I installed the WD drive, and when the system is booted, the drive is recognized in the POST. But when I run WinXP setup from CD, everything loads, and about 30 seconsds after it says “Starting Windows” I get a BSOD: STOP 0x0000007B (0xF78D2524, 0xC0000034, 0, 0). I tried this many times, always the same exact result.

I’ve searched via google and seen a lot of chatter about this, and I’ve tried the following, all to no avail:

 -  changed SATA OPERATION from AHCI to ATA in the BIOS; when I do this the system won’t even read from the CD. I simply get a flashing cursor in the upper left corner of the screen after the POST

 - replaced the SATA data cable

 - put a jumper on pins 5-6 to slow the drive down to 3Gb/s

At this point, I’m thinking that one or more of the following applies …

  1) this drive requires a driver that must be installed via F6 at the start of Windows XP setup

  2) the drive is bad

  3) the drive controller on the motherboard is bad

  4) I just have bad kharma   :slight_smile:

Can anyone offer any guidance about this?  I’m sure puzzled and stumped.


Hi, first verify if the hard drive is faulty using DLG boot disk to run a test, if the hard drive is OK then it could be an outdated driver for the controller card, check if you can download it from the Dell web page.

1 Like

Thanks for the reply Alucardx23,

The link you supplied brought me to a page that indicated that WD is no longer providing DLG, so I downloaded Acronis, installed it on another computer and created a boot disk. Acronis was able to see the disk and partition it.

Looking at another page on the WD website, I found a download of DLG. I downloaded that, burned it to a boot disk. When I boot to this, after a pause of a minute or so, I get the message


So, at this point I still don’t know if the drive is OK - I’m assuming so because Acronis did create 4 NTFS partitions.

Looking on the Dell web site, I found no driver for the controller. It looks like the controller is on the mother board (the only card in the machine is a video card). I see some tantilizing possibilities, but choosing the right driver requires knowing details about the hardware that are hard to come by.

OK, so I put the old drive back in the machine, and booted DLG - same result!

Now I’m really not sure where the heck I stand …LIGHTBULB - I boot the old drive into Windows safe mode - yes the bad drive will boot safe mode. I see there’ s a “C:\drivers” folder and sure enough, an AHCI driver is in there. I copy it to a floppy, pute the new drive back in and run windows setup, pressing F6. setup loads the driver and moves on!

Setup completes - I remove the CD, windows is starting up and …
Error loading operating system

Sigh … Googling this, it seems that this is most often caused by an outated BIOS. I look on the Dell web site, and, according to the version number, the machine already has the latest BIOS. But inside of setup, the BIOS bears a date of 5/2007, but on the Dell web site shows a release date of 8/2007 - but both are version 2.0.4.

OK, I download the BIOS and flash it anyway - same result. I start from scratch, letting windows install itself again, with the AHCI driver, AND partition the drive, and formt it (the looooong way) … same result: Error loading operating system

Well, if the BIOS really is outdated, and can’t be updated, perhaps this machine simply can’t use this drive … ah dunno … I’m just kinda stuck now … :frowning:

Since you did solve my orinal problem, I’m clicking your star.

If anyone can shed any light on this situation, I’m all ears … otherwise I just have a new boat anchor …


Well, I purchased a WD1002FAEX (1 TB caviar black), and using the hard disk driver (via F6 during Windows setup), it all just worked. I don’t know if there is a problem with the 750 GB WD7500AALX  … or it’s just not compatible with my machine … I’m guessing the latter.