Problem with WD30EFRX 3.0T external drive

Hi forum…

A friend has one of these as an external drive and today while Skying him it failed, the drive starts to spin up but isn’t recognised. He took it out of the caddy and tried another one and it was the same issue,

Sadly he has a LOT of data on there and yep, you guessed it, no backup.

I’ve heard of swapping the logic board but not sure of the process apart from unscrewing it.

Any idea’s of an issue / fix please…

He’s in his late 60’s with artrhritis so it would be me doing it, I’m not bad with a soldering iron and used to work at Maplin Electronics so I’m semi tech litterate :slight_smile:

Welcome to the Community.

A logic board exchange is not recommended without extensive knowledge of component integration, and differences in production batch and firmware revisions need to be taken into account as well.

Since this is a delicate situation perhaps it would be best to consult a dedicated data recovery service. The following link lists recommended specialists.

“He took it out of the caddy and tried another one and it was the same issue”

Reading this sentence literally, it sounds like the external dock (what you called a caddy) is the problem. Do you know someone with an external dock you can borrow for an hour? With computers, there are so many variables that you need to eliminate some. And the moderator is correct regarding swapping parts; unless you had two drives manufactured within a short time frame, that is not recommended.