Problem with WD TV live and .mkv files that have been muxed with mkvmerge


#1

Hello,

I recently tried to play some .mkv files on my WD TV live player, but the AC3 audio is not playing (despite it being recognised). The video and subs work fine.

This happens only when the mkv files have been through the mkvmerge program (muxing in the subs for example). Even selecting a .mkv file that works fine, and remuxing it with no changes to the streams/file using mkvmerge gives an output file which causes problems with the WD TV. Strangely, everything is fine when I play the file in WMP 12.

Has anyone else experienced this issue? Is there any workaround?

Thanks,

Odai.  


#2

I never have this issue (and I use mkvmerge to mux in subs with every single MKV file I produce).  However, I passthrough the AC3 track (via the selection “digital” in the Audio/video settings menu in the Live) and then decode it with my AV receiver.  Are you using “stereo” (the default) there?  If not, how are you decoding the audio?


#3

What version of MKVmerge did you use? Somebody had a problem with the latest version which was corrected by simply running the file back through an earlier version. This involved lack of sound.


#4

Hello,

Thanks for your help guys.

I’m using the “stereo” option on the WD TV live, so nothing complicated.

The version of mkvmerge I used is the very latest one, 4.1.1. I’ll try finding the previous version. So all I have to do is simply re-mux the affected files in the previous version, with no alteration of the settings at all? 


#5

Western Digital will have to fix it pretty fast.

Take a look here: http://www.bunkus.org/videotools/mkvtoolnix/faq.html#header_removal_compression

You can use the latest version but will have to disable the extra compression for audio tracks.


#6

Ah, OK. Thanks a lot for that, I see what is wrong.

I did run the files through the old version of mkvmerge, and it seems to have fixed everything.

I did think of maybe forwarding this to WD by email, but looking around they seem to have a pretty poor record of fixing issues with the player. :dizzy_face:


#7

Well, that definitely ■■■■■.  There appears to be no way to permanently set the default for this, unless you want to be manually loading a settings file into mkvmerge everytime you use it.

Meanwhile, I don’t necessarily agree with the statement in the MKV FAQ:


This feature has been part of the Matroska specification since more than six years, and there’s no excuse for refusing to add support for it.


The reason I disagree with this is because there are features in Xvid (e.g. Global Motion Compensation) that have been around for many years, yet most hardware playback devices don’t support these advanced features.  For the mkvmerge author to try to wash his hands of this is downright ignorant, especially since he has now effectively broken the app for all WD TV Live units (and possibly others, such as the Acer O!Play line).  That’s not to say that I’m against having the compression option added to mkvmerge; it’s just that “none” should be the default choice.

At any rate, here is a link to MKVToolnix 4.0.0 (this was the last version released before compression was enabled):

http://www.bunkus.org/videotools/mkvtoolnix/win32/mkvtoolnix-unicode-4.0.0-setup.exe

Regards,

Visor


#8

Welcome to the forums.

I tend to agree with you – I also think it’s a good idea not to fix something that isn’t broken (which is why I’m still using a version of mkvmerge that is at least a year old – works great for me and I don’t need anything else).

Thanks for providing that link for others.