Problem with WD My Passport 2tb (USB3.0)

I recently bought a WD My Passport 2tb (USB3.0) at first I was really happy with it. I copied over all my smaller harddisk so i had everything on one disk… Until a few days later I discovered that some of the transfered files are corrupted… So I ran a full disk scan, but it gave no result (as in the disk should be ok).

[Window Title]
Checking Disk Local Disk (G:)

[Main Instruction]
Your device or disk was successfully scanned

No problems were found on the device or disk. It is ready to use.

If you removed the device or disk before all files were fully written to it, parts of some files might still be missing. If so, go back to the source and recopy those files to your device or disk.

[^] Hide details [Close]

[Expanded Information]

CHKDSK is verifying files (stage 1 of 5)...
  6912 file records processed.                                         

File verification completed.
  13 large file records processed.                                   

  0 bad file records processed.                                     

  0 EA records processed.                                           

  0 reparse records processed.                                      

CHKDSK is verifying indexes (stage 2 of 5)...
  7174 index entries processed.                                        

Index verification completed.

CHKDSK is verifying security descriptors (stage 3 of 5)...
  6912 file SDs/SIDs processed.                                        

Security descriptor verification completed.
  131 data files processed.                                           

CHKDSK is verifying file data (stage 4 of 5)...
  6896 files processed.                                                

File data verification completed.
CHKDSK is verifying free space (stage 5 of 5)...
  2065252 free clusters processed.                                        

Free space verification is complete.
Windows has checked the file system and found no problems.

1953480703 KB total disk space.
1821218560 KB in 4625 files.
      9024 KB in 133 indexes.
     76991 KB in use by the system.
     65536 KB occupied by the log file.
 132176128 KB available on disk.

     65536 bytes in each allocation unit.
  30523135 total allocation units on disk.
   2065252 allocation units available on disk.

At first I had the idea the source files might have been corrupted too, but after testing them they had no problems at all… So I started copying over a few files again, only to discover again that some files got corrupted again (but different ones then the first time). So I deleted the files which I knew that where corrupted and copied them over again, which worked for some, but other still got corrupted (on different places then the first time)… Now I really dont understand anymore what is going on… It just looks like files get randomly corrupted while writing them to this disk (which i dont trust anymore at all)… But the weird part is that according to windows the disk is perfectly fine…

Can anyone explain to me why the files get corrupted while copying them over to this new disk?


One thing that you can try, is to move the files out of the drive and write zeros to the drive and then test the unit with DLG tool to see if you have any bad sectors affecting the drive…

Check the link below.

For information on proper handling and installation of wd drives, please refer to the following link.